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Connecting your PC to a sign 

 Installing AlphaNET
™

 3.0 
 

 and setting up sites 
 

   
 

 
 
 
 
 
 
 
 
 
 
 
 

This chapter explains the basics of 

connecting your personal computer to a 

sign. 

 
 
 
 
 
 
 
 
 
 
 
 

This chapter shows you how to  

install the AlphaNET
™

 3.0 software 

on your personal computer. 
 

Also, a step-by-step tutorial explains 

the basics of creating sites using Site 

Manager. 
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 Creating and sending messages Reference 
 
 
 
 
 
 
 
 
 
 
 

 

This chapter explains how to create 

and send messages with Message 

Editor, as well as how to include 

graphics and animation in your 

messages. 

 
 
 
 
 
 
 
 
 
 
 

 

This chapter contains quick 

reference summaries of Message 

Editor, Site Manager, Communications  
Manager, and Diagnostics in the  

AlphaNET
™

 3.0 software. 
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What’s new in AlphaNET
™

 version 3.0 software 

 

Password protection 
 
Site Manager and Message Editor can now be password-protected. Select Set Password from 

the Edit drop-down menu: 

 
Type a new password in the New 

Password line, then press Tab.  
Type the same password in the 

Verify box and click OK. 

 
When changing the password, you must 

first type the password to be changed in  
the Old Password line. 

 

Menu customization 
 
You can customize the options appearing in the drop-down menus in Message Editor by selecting  
Edit>Customize: 
 
 
The type of sign selected 

determines the options 

 available in your 

drop-down menus. 
 

Select how you want the icons 

in your messages to appear, 

as pictures or as text. 
 

Type the number of spaces 

to insert for a tab setting. 
 

Color selection 
 
A new color selection box is available for the AlphaEclipse™ Purecolor™ 3600 series sign 

(full color, not monochrome). In Message Editor, see Characters>Color>RGB. 
 
 

 
This color selection box also 

appears when you select  
Characters>Shadow in 

Message Editor to allow 

you to pick the shadow 

color of the characters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



New modes 
 

Two new modes are available with this version of AlphaNET™, Clock mode and Explode mode. 

Clock mode is a wipe mode that updates information as if a second hand were sweeping around 

the sign. Explode mode is a roll mode that moves information from the center of the sign and 

outward in all four directions at once. Both modes are available in Message Editor under the 

Modes drop-down menu.  
New line positions 

 
Two new line positions are available in Message Editor, Left and Right, which left- or right-

justify your message. 
 
 

These line positions are only available with the  
AlphaEclipse™ PureColor™ 3600 series sign. 

 
 
 

Tooltips 
 

Tooltips are now available in all components of AlphaNET 3.0. 

 
A Tooltip appears 

when you place the 

mouse over an icon 

in any component of 

AlphaNET. 
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Basic message editing 
 
 

Basic message editing 

 

Because AlphaNET
™

 3.0 software allows you an infinite number 

of ways to create a message for a sign, it is not possible to show every 

one. In the following pages, however, examples of basic and advanced 
message editing are presented.  

First, the basics. 
 

Using Message Editor to create your message  

1. After installing the AlphaNET
™ 3.0 software on your PC, open 

Message Editor. Then open a window for a new message: 
 

Select Start>Programs>AlphaNET >Message Editor  
or click the Message Editor button on the 

AlphaNET
™

 bar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Then click  to create a 

new message window. 
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Basic message editing 

 

2.  Type The first message in the window: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Use File>Simulate to view what the message will look like on a 
sign, or click the Simulate button on the toolbar: 

 
Click here to view what 

your message will look 

like on a sign. 
 
 
 
 
 
 
 
 
 
 
 
 

 
H I N T 

 
Right-click on the 

simulator and click 

Change Display to choose 

a different sign to emulate. 
 
The type of display 

you select appears on 

the title bar. 
 

 
Note:The type of sign on which your message is being 

simulated appears on the title bar of the window (in this case, an 

Alpha® 7120C). To change it, right-click anywhere on the 

simulated message and select Change Display. 
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Basic message editing 

 

4. Add the current date to your message. First, close the window in 
which your message is being simulated. Then select Options>Date  
in Message Editor: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In the Insert Date 

window, select OK 

and a date icon will 

appear at the end 

of the message. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5.  Then view your message again using the Simulate button: 
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Using modes to change the look of a message 
 

Modes are special effects that change the way a message appears on 

a sign. For example, the Rotate mode moves a message from right to left 

across a sign. In this example, you will create a message that displays 

employee birthdays.  
NOTE: Some modes are not available on some signs. For a list 

of what modes are available, see “Appendix B — Modes 

available on signs” on page 137. 
 

Example 1: How to display employee birthdays. 

 
In this example, the Hold and Rotate modes are used to display employee birthdays.  
This setup has a variety of uses, such as announcements and anniversaries. 
 
In the Hold mode, 

the top line remains 

fixed while the 

names go by. 
 
In the Rotate mode, 

the names move 

from right to left on 

the bottom line. 

 
 
 
 
 
 

 
See “Appendix E — Understanding 

message line positions (Top, Middle, 

Bottom, Fill)” on page 141. 

 
 
 
 

 
H I N T 

 
Place the cursor over an 

icon and click the right 

mouse button to see a 

short description of the 

icon at the bottom of the  
Message Editor 

window. For example: 
 
 
 
 
Click the right mouse button 
 
 
 
 
 
 
 
You can also switch 

between using pictures 

and using text 

descriptions for the 

icons by selecting Edit 

>Customize and 

changing the icon style 

 
 

6. To create Example 1, close the previous message but don’t save it. 
Next, open a new message. Then select Modes>Hold: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7.  When the following window appears, select Top and then OK: 
 
 

Line Position is where a  

message appears on a sign. 
See “Appendix E — 

Understanding message 

line positions (Top, 

Middle, Bottom, Fill)” on 

page 141 for more details. 

 

 



Basic message editing 
 
 
 
 

This little marker indicates 

that the text following this icon 

will appear on the top line of a 

display.  

 

 

8.  The icon for Hold will appear in the message window: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

9. Type Birthdays. Then select Modes>Rotate>Standard>Bottom. 
Click OK and then type: Tom White, Patty Smith, Bob Evan. 

 
Select Rotate>Standard 

 

 
...and the Bottom line position. 
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10. Next, click  to view your message: 
 
 
 

H I N T 
 
View (simulate) your message to see 

exactly how it will appear on a sign. 
 
You can see how fonts, colors, and 

graphics will appear on a sign and 

also how much text will appear on a 

line. (If text appears in white, this 

means it is too long to fit on the 

display. If possible, break the text 

into smaller segments.) 
 
For example, these pictures 

show how the message you 

just created would appear on a 

one-line Alpha® 215C sign. 
 
 
 
 
 
 
 
 
 

 

11. Save this message by selecting File>Save and then clicking OK: 
 

 
Make sure the file is saved 

 to this folder. 

 
Name the Example 1 message Alpha1.msw. 
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Using characters to change the look of a message 
 

Characters are options that change the appearance of text in a 

message. For example, normal-sized text (called Seven Row Normal) is 

seven rows of LEDs high, but some signs allow you to create text 15 or 

16 rows high with the 15/16 Row Normal option. In this example, we 

will create a message that displays airline fares.  
NOTE: Some characters are not available on some signs. For a 

list of what is available, see “Appendix C — Character 

fonts and colors available on signs” on page 139. 
 

Example 2: How to display airline fares. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

O O P S ! 
 
By selecting Top, we 

have made an error 

that will show up later. 
 
The purpose of this is 

to demonstrate a 

common mistake and 

how to correct it. 

 

 
In this example, the Roll mode, 15/16 Row Normal text, and the New Line 

option are used to display airline prices for several cities. Just like Example 1, 

this setup has a variety of uses, such as announcements and anniversaries. 
 

 
A single message will 

be used to create 

large text on two-line 

signs and normal text 

on one-line signs. 
 

 

12. Select File>New to open a new message. 
 
13. Then select Modes>Roll>In: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

14. When the following window appears, select Top and then OK: 

 
 
 



Basic message editing 

 

15. Because we want large text, select Characters>15/16 Row Normal. 

Then type Las Vegas $85, Chicago $199, New York $235: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
15/16 Row Normal 

icon  
 
 
 
 
 
 

16. Let’s see how the message looks so far. First, let’s try a one-line 
sign. Simulate your message and change the sign to a 215C. (If you 
do not remember how to do this, see step 3.) The message should 
look like this: 

 
Since a one-line sign like the 215C 

cannot display the 15/16 Row 

Normal characters, the sign 

displays Seven Row Normal 

instead. But this is what we wanted. 
 

17. Change the sign to a 4120C, a two-line sign. (If you do not 
remember how to do this, see step 3.) This is how it should look: 

 
 

 

Why doesn’t the large text appear on the two-line 4120C sign like 

we wanted? Because in a previous step we selected the Top instead 

of the Middle or Fill line position: 
 

To make the large 15/16 

Row Normal text appear 

correctly, the line position 

must be changed to Middle. 
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18. To make the large 15/16 Row characters appear correctly on a two-
line sign, start by deleting the Roll>In icon from the message: 

 
 
 
 

 
To delete the Roll In icon, place the 

cursor to the right of the icon and press 

the BackSpace key on your keyboard. 
 
 
 
 
 
 
 
 
 

 

19. Next, without moving the cursor in the message, select Modes> 
Roll>In as you did before. When the following window appears, 
select the Middle line position: 

 
 
 
 
 
 
 
 

 

20. Simulate the message using a two-line sign like the 4120C. (If you 
do not remember how to do this, see step 3.) The 15/16 Row Normal 
text should now appear correctly: 

 
 

 

Your message text should look like this: 

 
Notice that this marker on 

the Roll>In icon has changed 

to the middle, indicating the 

new line position. 
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O O P S ! 
 
Using a carriage return 

might seem like the logical 

way to format lines of text 

in a message, but it does 

not work. 
 
We will correct this later 

with the New Line option. 

Basic message editing 

 

21. Save your message and name it Alpha2.msw. However, keep using 
the message for the following steps.  

22. Now we will try displaying a city name and dollar amount on a 
sign at the same time. 

 
Try deleting the comma and space between each city and 

amount pair. Then place a carriage return after each, like this: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A carriage return has been 

placed after each line of text. 
 

23. Next, simulate the message to see how carriage returns affect the 
message format. This is what you should see: 

 
 
 
 
 
 
 
 
 

Carriage returns do 

not break text into 

separate lines. 
 

The New Line option 

must be used instead. 
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24. To format the text so that Las Vegas $85 and Chicago $ 199 and 
New York $235 all appear on separate lines, add the New Line option 

after each city and amount pair. To do this, use the Options menu: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 These are New Line icons. 
 
 
 
 
 
 

 

25. Simulate the message to see how New Lines affect the message 
format. This is what you should see: 

 
 
 
 
 
 
 
 
 

The New Line option 

formats the text correctly. 
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Using international characters 
 

International characters—such as the é in résumé—are available 

in French, German, Italian, Spanish, and Croatian. 
 

Additional characters are also available. Check the Character 

Map accessory to see if contains the character you want.  
NOTE: These instructions are for a Windows® 95 operating 

system; menu selections and screens may be different 

in other versions of Windows®.  
Follow this procedure to use international characters: 

 
Step Procedure  

From the Windows® Start menu, select Find and then Files or Folders: 
 
 
 

 
1 

 
 
 
 
 

 
Use Find to locate the editor.ini file and then double-click it to open: 

 
 
 
 
 
 
 
 

2 
 
 
 

 

Double-click the file to open it. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Basic message editing 
 

 
Step Procedure  

The editor.ini file will look something like this: 
 
 
 
 
 
 
 

3 
 
 
 
 
 
 
 

 
Type the following line exactly as shown:  
DefaultFont=Terminal 

 
4 

 
 
 

 
Then save the change and exit this window: 

 

 
5 

 
 
 
 

Next, open Message Editor. Select File>New. Type This is a test: 
 

 
6 

 
 
 
 

From the Windows® Start menu, select Programs>Accessories>Character  
Map (or Program>Accessories>System Tools>Character Map): 

 
 
 

 
7 
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Step Procedure  

Imagine you want to add the letter ä to your message: 
 

First, set Font to Terminal. Second, click the letter ä. 
 
 
 
 

 
8 

 
 
 
 
 
 

Third, note the keystroke. You must hold Alt and type 

 0132 to create the international character ä. 
 

Return to Message Editor. Add the ä character to the message by 

typing 0132 while holding down the Alt key on your keyboard: 
 

 
9 

 
 
 
 

 
Finally, to make sure you have actually created the character 

you want, simulate the message: 
 
 
 
 
 
 
 

10 NOTE: You cannot use characters created by holding down the Ctrl key and 
 

typing the combination. For example, you will not be able to use the Ç 
 

 
 

 character because it is created by using Ctrl and 2. 
 

 Also, you can only use Alt with numbers less than 0169 to create 
 

 characters. 
 

 For example, you can use Alt and 0168 to create the letter ¿, but Alt 
 

 and 0169, Alt and 0170, and so on, will not create the correct 
 

 characters and should, therefore, not be used. 
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How to send a message to a sign 

 

What happens when messages are sent to a sign? 
 

Messages are sent to signs using either Message Editor or Site 

Manager. One message at a time is sent from Message Editor, and it 

erases all other messages in the sign’s memory. This one message, 

then, plays over and over.  
More than one message at a time can be sent from Site Manager, and 

they erase all other messages in the sign’s memory. These new messages 

are then displayed one after the other.  
When a single message is sent with Message Editor: When more than one message is sent with Site Manager: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
After creating a message in Message Editor,  

select  to send the message to one or more sites. 
 
 
 
 
 
Each message 

packet sent includes 

the date and time 

from the sending PC. 

The clock inside the 

sign will be updated, 

even if the message 

doesn’t include the 

date or time. 

 
1 message repeated 

 
 

 
ANNIV1.MSW 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
After creating messages in Message Editor and then 

saving them, open Site Manager. Select the sites to 

which you want to add messages, then click  . 
 
 
 
 
 
 
 
 
 

 

Then select  to send the messages. 

 
3 messages repeated 

 
 
 

 
ANNIV1.MSW 

 
 

BIRTH1.MSW 
 
 

CUSTOM.MSW 
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Sending messages from Message Editor 
 
 

H I N T 
 
Generally, only send 

messages from 

Message Editor when: 
• testing to see how a 

message looks, or 

• there is only one sign. 

 

1. Before sending a message, you must create at least one site using Site 

Manager. (See Step-by- step tutorial in setting up connection devices, 
sites, and groups in Chapter 2.) 
 
 

 

2. Next, create your message in Message Editor. When you are 
finished, send it to one or more sites: 

 
 
 
 

 
Click to transmit the message: 

 
• To All Sites — every site you have created 

in Site Manager or 

 
• To Selected Sites — only those Site 

Manager sites that have been specially 

selected as Use as an Editor transmit site. 

(See “R & D setup (1 of 4): Site Editor (Site 

Info) window” on page 30 in Chapter 2.) 
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Sending messages from Site Manager 
 
 

H I N T 
 
To select more than one 

site, first hold down the Ctrl 

key on your keyboard, then 

click the sites: 

 

1. Before sending a message, you must create at least one site using Site 

Manager. (See Step-by- step tutorial in setting up connection devices, 
sites, and groups in Chapter 2.) 
 

 

2. If you have not already done so, add your message to the site (or 
sites) to which you want the message sent: 
 
 
 
 
 
 
 
 

Select to add a message 

to the Sales site. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Next, select the message. The message can be edited, scheduled by 
day, date, and time, or transmitted immediately: 
 
 
 

Select to set the day, date, and time when 
 

the message will start and stop on the Sales 

signs, or 
 

select to edit the message in Message Editor 
 

before sending it, or 
 

select  to transmit the message 

immediately to all the signs in the Sales site. 
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The difference between all messages and common messages 
 

When you select a single site, all the messages attached (added) to 

the site will appear in the Site Manager window. However, when you 

select more than one site, only the messages that are common to both 

will appear. 
 
 
 
 
 
 

 
When the 

Engineering site is 

selected, all the 

messages attached 

to the site appear. 
 
 
 
 
 
 
 
 
 
 
 
 

 
Also, when the 

Manufacturing site 

is selected, all the 

messages attached 

to the site appear. 
 
 
 
 
 
 
 
 
 
 
 
 

 
However, when both 

sites are selected, 

then only the 

messages that are 

common to both 

sites will appear. 
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How to use graphics in messages 

 

 
H I N T 

 
Example graphic files are 

included with AlphaNET™ 

3.0 software. 
 
Look in the Samples 

folder installed on your 

computer. 

 
 

The Animation, Graphic, Flick, and Gif options allow you to include 

small pictures in messages. Use the Graphic option to display single 

bitmapped images, and the Animation, Flick, or Gif option to display 

multiple images—like a movie. Note that not all signs display animations.  
For the Graphic, Flick, and Gif options, you can create the images 

yourself, use the animations provided (such as Running Animal, which 

shows a horse running across the sign), use the gif files provided, or 

pull an image from another source, such as the Internet.  
Animation, Graphic, Flick, and Gif are in the Options menu: 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

Creating a graphic 
 

Before you actually start drawing, make sure you understand how 

a bitmapped image is displayed on a sign. See “Graphics must be 

bitmapped to a sign’s columns and rows” on page 149.  
You will need a program to create and edit bitmapped images. Image 

editing software examples in this manual illustrate version 5.03 of Paint Shop 

Pro (the steps are similar for newer versions of Paint Shop Pro).  
Any image editing program can be used (See “Paint Shop Pro — 

an image editor” on page 150.) 
 

Example 3: How to use a graphic in a message 
 

 
In this example, arrow bitmap images are created to demonstrate the Graphic option. 

 
The two arrow bitmaps 

we will make are 7 rows 

(or pixels) high. This 

means the arrows can 

be used on one-line as 

well as two-line signs. 

 
 
 
 
 
 
 



 
 
 
 
 
 

 
H I N T 

 
Most image editing 

programs create images 

similar to Paint Shop Pro. 
 
However, if you are not 

using Paint Shop Pro, 

consider using software 

that has a zoom feature 

so you can increase the 

size of the bitmap for 

ease of editing. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

H I N T 
 
Because a maximum of 

8 colors can be used on 

signs, select 16 colors 

instead of 256 in your 

image editing program. 

How to use graphics in messages 

 

1.  Select Start>Programs>Paint Shop Pro to open Paint Shop Pro: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2. Next, select File>New. When the New Image window appears, 
make the width and height of the new bitmap 16 x 7: 

 
NOTE: Width and Height define the size of the bitmap in 

pixels—16 pixels wide x 7 pixels tall. These 

numbers also correspond to a sign’s columns and 

rows—16 columns wide x 7 rows tall. 
 
 
 
 

 
We are using 7 

because this is the 

height of a single line of 

normal text on a sign. 
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3. A very small window will appear. Use the zoom tool to click in the 
window to increase its size to 16:1: 

 
 
 
 

H I N T 
 

Use the zoom feature 

to increase the size of 

the small window until 

the window says 16:1. 
 

At 16:1, editing the 

graphic is much easier. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
H I N T 

 
Depending on the model 

of the sign some colors 

do not effectively appear 

on the sign display. 
 
For more information see 

“A graphic may be the 

wrong color for some 

signs” on page 149. 

 
 
 
 
 
 
 
 
 
 

 

4. Select a color for your graphic from the blended palette on the right-

hand side of your screen. You can also double -click the foreground 

or background rectangle underneath the blended palette to choose a 

color from a sectioned palette. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The sectioned 

palette  
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5. Then draw the right arrow and save it as a BMP bitmap named 
rarrow.bmp: 

 
 
 
 
 
 
 
 
 
 
 

Name the graphic rarrow.bmp. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Create the other arrow (shown below) using steps 2 through 4 and 
save it as larrow.bmp: 

 
 
 
 
 
 
 

 

7.  Next, open Message Editor. Then select File>New: 
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8.  Select Modes>Hold, using the Middle line position. Then select 

Options>Graphic. When the Select Graphic window appears, 

choose the rarrow.bmp (right arrow) file you just created: 
 

N O T E 
 

For graphics, any mode can 

be used. For flicks, the Hold 

mode must be used. 
 

For either graphics or 

flicks, the mode 

selected must use the 

Middle line position. 
 
 
 
 
 

9. An icon representing the graphic will appear. Type News after it. Put 

a space before and after News. Finally, put the left arrow bitmap 
(larrow.bmp) after News. This is what you should now see: 

 
 
 
 
 
 
 
 

Hold mode (middle) 
 

Right arrow graphic icon 
 

Left arrow graphic icon 
 
 

10. Simulate your message to see what it looks like: 
 
 

This is how the message looks on the two-

line Alpha® 4120C sign.  
 

This is how the message looks on 

the one-line Alpha® 215C sign. 
 
 

Note:Graphics that are 24 rows high should be displayed and 

simulated on 3-line signs (or greater) and not on one- or two-

line signs where the graphics will appear garbled. 
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Creating a flick 
 

NOTE: The Flick option only works with AlphaVision™ and 

Series 7000 signs. However, see “Another way to 

create a flick” on page 76 to create an animation on 

another type of sign.  
A flick is a series of bitmap images that are shown one after the 

other, which gives the illusion of movement on a sign. The Flick option 

is used to put a movie in a message, and is made up of individual 

bitmapped images that you must create.  
You will need a program to create and edit bitmapped images. Image 

editing software examples in this manual illustrate version 5.03 of Paint Shop 

Pro (the steps are similar for newer versions of Paint Shop Pro).  
Any image editing program can be used (See “Paint Shop Pro — 

an image editor” on page 150.) 
 

Example 4: How to use a flick in a message 
 
 

In this example, we will create a ship that sails across an Alpha® 7120C sign. 
 
 
 
 
 
 

 
A flick is made up of many bitmap files that are played one after the other. 

 
Each bitmap file in a flick must fill the total display area of the sign it is displayed on.  
This means that a flick is usually designed for one sign. 

 
In this example, each bitmap is 120 x 24 pixels because we are playing the 

flick on a 7120C sign whose total display area is 120 columns x 24 rows. 
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1.  Select Start>Programs>Paint Shop Pro to open Paint Shop Pro: 
 
 

H I N T 
 

Most image editing 

programs create images 

similar to Paint Shop Pro. 
 

However, if you are not 

using Paint Shop Pro, 

consider using software 

that has a zoom feature 

so you can increase the 

size of the bitmap for 

ease of editing. 
 
 
 
 
 
 

 

2. Next, select File>New. When the New Image window appears, 
make the width and height of the bitmap 120 x24 pixels. 

 
Each graphic in the flick for the Alpha® 7120C sign must be this 

size. 
 

NOTE: Width and Height define the size of the bitmap in 

pixels—120 pixels wide x 24 pixels high. These 

numbers correspond to the 7120C’s columns and 

rows—120 columns wide x 24 rows tall. 

 
H I N T 

 
Because a maximum of 

8 colors can be used on 

signs, select 16 colors 

instead of 256 in your 

image editing program. 

 
We’re using 120 x 24 for 

width and height because 

this is the total display area 

of an Alpha® 7120C sign. 
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3. A very small window will appear. Use the zoom tool to click in the 
window to increase its size: 

 
 
 
 
 
 
Use the zoom feature to 

increase the size of the small 

window to make editing the 

graphic much easier. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
H I N T 

 
Depending on the model 

of the sign some colors 

do not effectively appear 

on the sign display. 
 
For more information see 

“A graphic may be the 

wrong color for some 

signs” on page 149. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Select a color for your graphic from the blended palette on the right-

hand side of your screen. You can also double -click the foreground 

or background rectangle underneath the blended palette to choose a 

color from a sectioned palette. 
 
 
 
 
 
 
 
 
 
 
 
 
The sectioned 

palette  
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5.  Then draw the first bitmap image: 
 
 
 
 
 

The first bitmap in this flick 

will show a ship entering 

from the left side of the sign. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

6. After you are finished drawing the first bitmap, save it—and all 
the other flick bitmaps—in a folder named ship. 

 
Name this first bitmap ship00.bmp and save it as a BMP file: 

 
 

H I N T 
 
Even though up to 100 

bitmaps can be in a 

flick, keep in mind that 

a sign’s memory 

capacity is limited. 
 
So experiment first with 

small flicks on a sign. 

 
NOTE: The name of each bitmap in a flick is important. The first 

bitmap’s name must end with 00, such as ship00.bmp. The 

second bitmaps’s name must end with 01, such as 

ship01.bmp. The third bitmap’s name must end with 02, 

such as ship02.bmp, and so on. Up to 100 bitmaps can be 

in a flick and must be numbered 00 to 99, such as  
ship00.bmp through ship99.bmp. 
 

Save all the flick bitmaps in 

the special folder you created. 
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7. Create the other bitmaps in the flick. Each bitmap file must end with 

a consecutive number—00, 01, 02, and so on—and each bitmap must 
be saved as a BMP file in a special folder for the flick (ship, in this 
case). 

 
The completed flick of 11 bitmaps shows a ship crossing the 

screen. When the ship is about mid-screen, a submarine periscope 

appears in front of the ship. The periscope disappears as the ship 

passes above it, but pops up again behind the ship, looks around, 

then goes under water. 
 
 

ship00.bmp  
.  
.  
.  

ship01.bmp  
.  
.  
.  

ship02.bmp  
.  
.  
.  

ship03.bmp  
.  
.  
.  

ship04.bmp  
.  
.  
.  

ship05.bmp  
.  
.  
.  

ship06.bmp  
.  
.  
.  

ship07.bmp  
.  
.  
.  

ship08.bmp  
.  
.  
.  

ship09.bmp  
.  
.  
.  

ship10.bmp 
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Another way to create a flick 
 

Though the Flick option will only work with AlphaVision™ and 

Series 7000 signs, there is another way to create the illusion of motion 

on a sign.  
The Graphic option can be used to place one graphic after another in 

a message: 
 
 

Use the Hold mode 

(with the Middle line 

position) and Speed 

(No Hold) option in 

front of the graphics. 
 

This is necessary in 

order to turn off the 

Automode feature so 

that the graphics will 

display correctly. 
 
 
 
 
 
 

ship00.bmp through ship05.bmp 
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Creating a GIF 
 
 
 
 
 
 

H I N T 
 
Most image editing 

programs can create GIF 

images similar to Paint 

Shop Pro Animation. 
 
However, if you are not 

using Paint Shop Pro 

Animation, consider using 

software that has a zoom 

feature so you can 

increase the size of the 

bitmap for ease of editing. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
H I N T 

 
Depending on the model 

of the sign some colors 

do not effectively appear 

on the sign display. 
 
For more information see 

“A graphic may be the 

wrong color for some 

signs” on page 149. 

How to use graphics in messages 
 
 
 

 
NOTE: The GIF option will only work with the 7000 series, 9000  

series, AlphaVision
™

 (full matrix), and AlphaEclipse
™

 

signs. If a different sign is used, Extended Memory must 
be checked on the Sign Info tab of Site Editor in order 

for this feature to work.  
A GIF contains multiple images in one file that simulate animation, 

such as a hummingbird hovering above a flower. The GIF option is used 

to put moving animation in messages, and you can use the GIF files 

provided or create your own (see the example below). Note that GIF 

files are available on Adaptive’s Web site at http://www.ams-

i.com/Pages/ gif.htm, free and formatted.  
You will need a program to create and edit your GIF images. Image 

editing software examples in this manual illustrate version 5.03 of Paint 

Shop Pro (the steps are similar for newer versions of Paint Shop Pro).  
Any image editing program can be used (See “Paint Shop Pro — an 

image editor” on page 150.)  
The following instructions explain how to create a GIF using Paint 

Shop Pro Animation. 

 

1. Using your Internet browser, log onto the Adaptive Micro Systems 
Web site at http://www.adaptivedisplays.com/sample.htm.  

2. In the upper right-hand corner of Adaptive’s main page, right-click 
on the Tell a Friend graphic and select Save Picture As. 

 
Right-click on this graphic 

and select Save Picture As. 
 

3. Save the file as a GIF file to your C:\Program Files\Adaptive 
Micro Systems\AlphaNET directory.  

4. Select Start>Programs>Paint Shop Pro>Animation Shop, or open 
the image editing program you are using.  

5. Select File>Open and select your GIF file. Then click Open.  
6. Change any colors in the GIF file if they are incompatible with  

your sign. 
 

Note:If black or white is used in a GIF or BMP file, the sign thinks 

you want it to turn off those particular LEDs. Try using a different 

color. 
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7. Select Edit>Resize Animation and resize the file to your sign’s 
specifications. Make sure the Maintain aspect ratio box is checked, 
and then click OK: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

8.  Select File>Save. Then click the Customize button on the  
Animation Quality Versus Output Size window that appears. 

 
NOTE: This window appears when you save a file for the first time 

and then when changes are made to it. However, the 

settings you enter will become the default settings until you 

close Paint Shop Pro Animation. 
 

9.  On the Colors tab, make sure the settings are as follows: 
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10. On the Optimizations tab, uncheck all the boxes and click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

11. Click the Next button to cycle through the remaining windows.  
12. Select File>Close to close your GIF file.  
13. Next, open Message Editor and create a new message. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

14. Select Modes>Hold, using the Fill line position. 
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15. Select Option>Gif. Then select your GIF file and click OK. An 
icon representing the Hold mode and one representing the GIF will 
appear in your message. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

16. Simulate your message to see what it looks like: 
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How to edit a counter file 

 

What is a counter file? 
 

A counter file sets up from 1 to 5 numerical counters (counter 1 through 

counter 5), which can be used for either or both of the following: 
 

Display information in minutes, hours, or days on a sign. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A counter can be placed inside a message. 

(This one is counting down from 60 minutes.) 
 
 
 
 

 

Display special messages (target files) on a sign after a set amount 

of time has passed. 
 
 
 
 
 
 
 

After 50 days, the counter included in the top message (which counts 

up from 0 to 50) is set up to display the target message below: 

 
 
 
 
 
 
 
 
 
 
 

 
ON - OFF   SOUND  

P R O G R A M   RUN  

A P P E N D CURSOR SP ECIAL  FONT WI DT H COLOR  
R O L L WIPE S C R O

L L FLA S H HOLD R O T A T E  
1 2 3 4 5 6  

AUTO S P EE D TIME D OT    

7 8 9 0 SELECT  

A B C D E F  

# ¢ $ % & *  

G H I J K L  

< > = / + -  

M N O P Q R  

; : ” ’ , .  

S T U V W X  

? !   
RETURN  

Y Z SPAC E  

 
 
 
 
 
 
 

NOTE: The software necessary to use a counter file is included in 

the standard Alpha® firmware for signs and allows you 

to program a counter file from your computer. However, 

the standard Alpha® firmware does not allow you to 

program a counter file using an infrared remote control 

(left). 

 
SHIFT CAPS SHIFT 
 

INSER T BACK AD V DELETE 
 

 



How to edit a counter file 
 
 

Three examples of how to use counter files 
 

In these examples, we discuss three basic ways of using counters 

on signs: 

 
Addresses 

of signs  
Manufacturing Shipping Engineering 

 
 
Manufacturing 06 

 
Engineering 03 
 
Engineering 04 

 
Manufacturing 07 Shipping 00 Engineering 05 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
• Example 1 — Using a counter in a message on the Shipping sign. 

Counter 1 will be used to show a message that counts down hours. 

 
 

 

• Example 2 — Using a counter in a message and displaying a 

target file message on the Manufacturing signs. Counter 2 will be 

used to show a message that counts up days and display a target 

message when it reaches 50. 
 
 

 

• Example 3 — Using a counter to display a target message on the 

Engineering signs. Counter 2 will be used from Example 2. 
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Example 1 — Using a counter in a message 
 

In this example, we will end up with a message on the Shipping 

sign that counts down from 60 minutes over and over again: 
 

NOTE: The Shipping sign can still display other messages. 
 
 
 
 
 

 

1.  Open Message Editor and create a new message: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Add a counter to the message by selecting Options >Counter and 
then Counter 1. Then, after the counter icon, type a space followed  
by minutes before next shipment: 
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3.  Save this counter message as countshp.msw: 
 
 
 
 
 
 
 
 
 
 
 
 

 

4. After saving the message, close Message Editor. Open Site 
Manager and select Edit>Counter File: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Next, either open an existing counter file (like the default file 
shown below) or type a new file name (such as shipping.ctw): 
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6. When the Counter Setup window appears, select the Counter 1 
tab. Then type in the values as shown below: 

 
Table 15: Counter Example 1 — Counter 1 setup 

 
 
 

A 
 

B 
 
 
 
 

C 
 
 
 
 

D 
 
 

 

Item Name Directions 
 

     

 Counter 1–5  Select Counter 1 tab. 
 

      

A 
   This is where a message is assigned to a target 

 

Target Files 
 file. One to five messages can be displayed on a 

 

  
sign when counter 1 reaches its target value. (No  

    
 

    target files are used in this example.) 
 

     

 Counter On  Make sure this box is checked for this example. 
 

      

 
Increment Decrement 

In this example, select Decrement because we 
 

B want counter 1 to count down, not up.  

   
 

     

 Minutes  
Select Minutes because we want counter 1 to  

 
Hours  

 

  
count in units of minutes.  

 
Days  

 

   
 

      

   
Start 

Enter 60 because we want counter 1 to start at 60 
 

   
minutes and then count down to 0.  

 

Counter 
  

 

     

  

Target Enter 0.  

 Values  
 

     

   
Dec 

Enter 1 because we want counter 1 to count down 
 

   
1 minute at a time—60, 59, 58, and so on.  

    
 

      

C    This is where you would select which target file 
 

 Target  
One–Five 

messages to display when counter 1 reaches its 
 

 
Files  

target value. (No target files are used in this  

   
 

    example, so none are checked.) 
 

      

 
Counter 

 
Start TIme 

In this example, Always is selected because we 
 

  
want counter 1 running continuously. Since  

 
Run Time  

Stop Time  

  
Always is selected, Stop Time is not available.  

    
 

      

 
On Weekends Since we do not need our counter running on 

 

 
weekends, this is unchecked.  

    
 

      

D    This box is checked because we want our counter 
 

   

to count down continuously. If this box was not 
 

 
Auto Reload   

  
checked, counter 1 would count down from 60 to  

    
 

    0 just once. 
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7. Select OK after entering the setup information. Double-click the 
Shipping site to open the Site Editor window: 

 
 
 
 
 
 
 
 
 

 
Double-click  
Shipping. 
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8. Next, select the Sign Info tab and attach the counter file you just 
created to the Shipping site: 

 
 
 
 
 

 
D e l e t i n g a c o u n t e r f i l e 
 
If you want to delete a counter 

file from a sign, click Counter 

File, click None, and then click 
OK. 

 
 
 
 
 
 

After clicking Counter File, select the 

counter file you just edited (in this 

case, shipping.ctw). Then select OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Select OK. 
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9.  Add the message that contains counter 1 to the Shipping site: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Select Shipping. Then click  : 
 
 
 
 
 

 
Select the message 

that contains counter 

1 (countshp.msw). 
 

Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The message you added appears here, after 

any previously selected messages. The order in 

which the messages appear is the order in 

which they are sent to a sign. 
 

NOTE: If you want the new message at the start of 

the list, select the top existing message and then click 

 (Insert Message) instead of  (add  
message). 

 
 
 
 
 
 

 
88 3 — Creating and sending messages 



How to edit a counter file 

 

10. Finally, in order to display the message you just added to the 
Shipping sign, the message must be transmitted. To do this, select 
the Shipping site and then the transmit icon: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
R e s e t t i n g a c o u n t e r 
 
If you are prompted to 

reset a sign counter, 

select Yes to reset the 

counter to its start value. 
 
Otherwise, select No to leave 

the sign’s current value intact. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select Shipping because this is the only 

site to which we want messages sent. 
 

 
Click the Transmit icon. 

 
 
 
 
 
 

Click Selected 

Sites and then OK. 
 
 
 
 
 

 
All the messages 

will be sent to the 

Shipping site sign. 
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Example 2 — Using a counter in a message and displaying a target file message 
 

In this example, we will end up with a message on the Manufacturing 

signs that keeps track of the number of days without an accident. 
 

Also, when 50 days is reached, a message appears on the 

Manufacturing signs that reads Another 50 days without an accident! 

(this is called a target message.)  
NOTE: The Manufacturing signs can still display other 

messages. 
 
 
 
 
 
 

After 50 days, the counter included in the top 

message (which counts up from 0 to 50) is 

set up to display the target message below: 
 
 
 
 
 
 
 
 
 

1.  Open Message Editor and create a new message: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
90 3 — Creating and sending messages 



How to edit a counter file 

 

2. In the message window, type Days without an accident: and a 
space. Then add a counter to the message by selecting  
Options>Counter>Counter 2: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Save this counter message as countman.msw and close the 
message: 
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4. Next, create the target message — the message that will appear 
when counter 2 reaches 50 days. Then save this message as  
target1.msw: 

 
 
 
 
 
 

 
Save the target message as target1.msw. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Close Message Editor. Open Site Manager and select 
Edit>Counter File: 
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6. Next, either open an existing counter file or type a new file name 
(such as target.ctw) and click Open: 

 
 
 
 
 
 
 
 
 
 
 
 

 

7. When the Counter Setup window appears, select the Counter 2 tab 
and enter the values shown below: 

 
Table 16: Counter Example 2 — Counter 2 setup 

 
 
 
 

A 
 

B 
 
 
 
 

C 
 
 
 
 

D 
 
 
 

 

Item Name Directions 
 

    

 Counter 1–5 Select the Counter 2 tab. 
 

    

  This is where a message is assigned to a target 
 

A 
 file. One to five messages can be displayed on a 

 

Target Files 
sign when counter 2 reaches its target value. 

 

  
 

  The largest file runs indefinitely. Send a new 
 

  message to delete it. 
 

    

 Counter On Make sure this box is checked for this example. 
 

    

 Increment In this example select Increment because we want 
 

B Decrement counter 2 to count up, not down. 
 

   

 Minutes 
Select Days because we want counter 2 to count  

 
Hours  

 
in units of days.  

 
Days  
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Table 16: Counter Example 2 — Counter 2 setup 
 

  
Start 

Enter 0 because we want counter 2 to start at 0 
 

  
days and then count up to 50.  

 

Counter 
 

 

    

 

Target Enter 50.  

 Values  

    

  
Inc 

Enter 1 because we want counter 2 to count up 1 
 

  
day at a time — 1, 2, 3, and so on.  

   
 

C 
    

Target 
 Check One. This means that one message will 

 

 
One–Five appear on the sign after counter 2 has reached its  

 
Files  

  
target value.  

   
 

     

 
Counter 

Start  
 

 
Time In this example, Always is selected because we  

 
Run  

 
Stop want counter 2 running continuously.  

 
Time  

 
Time  

 

   
 

     

 
On Weekends 

Since we do not need our counter running on 
 

 
weekends, leave this unchecked.  

   
 

     

D   This box is checked because we want our counter 
 

  

to count continuously. If this box was not 
 

 
Auto Reload  

 
checked, counter 2 would count up to 50 just  

   
 

   once. 
 

     

 

8. Next, select the Target Files tab and for Target File 1, select 
Browse and then the file you created (target1.msw): 
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9. After selecting the target file, click Open, and then OK to close the 
Counter Setup window. Then double-click the Manufacturing site to 
access the Site Editor window: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Double-click Manufacturing. 
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10. Next, select the Sign Info tab and attach the counter file you just 
created to the Manufacturing site: 

 
 
 
 
 
 

 
D e l e t i n g a c o u n t e r f i l e 

 
If you want to delete a counter 

file from a sign, click Counter 

File, click None, and then click 
OK. 

 
 
 
 
 
 
 

After clicking Counter File, select the counter file you 

just edited (in this case, target.ctw.) Then select OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select OK. 
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11. Add the message that contains counter 2 to the Manufacturing site: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Select Manufacturing. Then select  : 
 
 
 
 

Select the 

message that 

contains counter 2 
(countman.msw). 

 
Click Open. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The message you added appears here, after 

any previously selected messages. The order in 

which the messages appear is the order in 

which they are sent to a sign. 
 

NOTE: If you want the new message at the start of the 

list, select the top existing message and then click 

 (Insert Message) instead of  (add  
message). 
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12. Finally, in order to display the message you just added, it must be 
transmitted to the Manufacturing signs. To do this, select the 
Manufacturing site and then the Transmit icon: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
R e s e t t i n g a c o u n t e r 

 
If you are prompted to reset a 

sign counter, select Yes to reset 

the counter to its start value. 
 
Otherwise, select No to leave 

the sign’s current value intact. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Select Manufacturing because this is the 

only site to which we want messages sent. 
 
 

Click the Transmit icon. 
 
 
 
 

 
Click Selected Sites 

and then OK. 

 
 
 
 
 
 

All the messages 

will be sent to the 

Manufacturing 

site signs. 
 
 
 
 
 
 
 

 
After 50 days, the counter included in the top message (which 

counts up from 0 to 50) will display the target message below: 
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Example 3 — Using a counter to display just a target message 

 
H I N T 

 
This example is nearly 

identical to Example 2. 
 
In Example 2, the counter 

was displayed as well as a 

target message. 
 
In Example 3, only the target 

message will be displayed. 

The counter will just count. 

 
In this example, we will use one of the five counters (in this case, 

counter 3) to display the message Another 100 hours of safe operation! 
When counter 3 reaches 100 hours, the message will appear on all the 

signs in the Engineering site. (This site was created in the previous 

section “How to change a sign’s serial address” on page 15.)  
NOTE: The Engineering signs can still display other messages. 

 
 
 
 
 

1. Open Message Editor and create a new message: 
 
 
 
 
 
 
2. Next, create the target message — the message that will appear  

when counter 3 reaches 100 hours. Then save this message as 

target2.msw: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Save the target 

message as 

target2.msw. 
 

3. After saving the target message, close Message Editor. Open Site 
Manager and select Edit>Counter File: 
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4. Next, either open an existing counter file (like the default file 
shown below) or type a new file name (like engineer.ctw): 

 
 
 
 
 
 
 
 
 
 
 
 

 

5. When the Counter Setup window appears, select the Counter 3 tab 
and enter the values shown below: 

 
Table 17: Counter Example 3 — Counter 3 setup 

 
 

 
A 

 
B 

 
 
 
 

C 
 
 
 
 

D 
 
 
 
 

Item Name Directions 
 

    

 Counter 1–5 Select the Counter 3 tab. 
 

    

  This is where a message is assigned to a target 
 

A 
 file. One to five messages can be displayed on a 

 

Target Files 
sign when counter 3 reaches its target value. 

 

  
 

  The largest file runs indefinitely. Send a new 
 

  message to delete it. 
 

    

 Counter On Make sure this box is checked for this example. 
 

    

 Increment In this example, select Increment because we 
 

B Decrement want counter 3 to count up, not down. 
 

   

 Minutes 
Select Hours because we want counter 3 to  

 
Hours  

 
count in units of hours.  

 
Days  

  
 

    

 
 
 
 

 
100 3 — Creating and sending messages 



How to edit a counter file 
 

 
Table 17: Counter Example 3 — Counter 3 setup 

 
   

Start 
Enter 0 because we want counter 3 to start at 0 

 

   
hours and then count up to 100.  

 

Counter 
  

 

     

  

Target Enter 100.  

 Values  
 

     

   
Inc 

Enter 1 because we want counter 3 to count up 1 
 

   
hour at a time—1, 2, 3, and so on.  

    
 

C 
     

Target   Check Two. This means that one message will 
 

  
One–Five appear on the sign after counter 3 has reached  

 
Files  

 

   
its target value.  

    
 

      

   Start  
 

 Counter  Time In this example, Always is selected because we 
 

 Run Time  Stop want counter 3 running continuously. 
 

   Time  
 

      

 
On Weekends 

Since we do not need our counter running on 
 

 
weekends, leave this unchecked.  

    
 

      

D    This box is checked because we want our 
 

   

counter to count down continuously. If this box 
 

 
Auto Reload   

  
was not checked, counter 3 would count up to  

    
 

    100 just once. 
 

      

 

6. Next, select Target Files. For Target File 1, select Browse and then 
select the file you created called target2.msw: 
 
 
 
 
 
 
 
 
 

7. After selecting the target file, click OK. Then double-click the 
Engineering site to access the Site Editor window: 
 
 

 
Double-click  
Engineering. 
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8. Next, select Sign Info and attach the counter file you just created to 
the Engineering site: 

 
 
 
 
 
 
 
 

 
D e l e t i n g a c o u n t e r f i l e 

 
If you want to delete a counter 

file from a sign, click Counter 

File, click None, and then click  
OK. 

 
 
 
 
 

After clicking Counter File, select the counter file you just 

edited (in this case, engineer.ctw). Then select OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Select OK. 
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How to use real-time data in a message 

 

String Variables + ActiveX® = real-time data 
 
 
 
 
 
 
 

H I N T 
 
The AlphaNET™ 3.0 

software CD ROM 

contains examples on 

using the Alpha® 

String Update Control. 

 
Data from external sources (for example, Microsoft® Excel, Access, 

and Visual Basic® software) can be displayed on Alpha® signs by using 

two features included in AlphaNET™ 3.0 software:  
• String variables 
 
• Alpha® String Update Control (an ActiveX® component)  

A variable in the AlphaNET™ 3.0 software represents real-time 

data that can change (for example, temperature or production rates, date, 

or time). Variables can be put into messages.  
The value of a variable can be changed using the Alpha® String 

Update Control. Because this is an ActiveX® control, it can be used 

with a variety of ActiveX®-compatible applications, such as 

Microsoft® Excel, Access, and Visual Basic® software.  
NOTE: Besides using the Alpha® String Update Control, you 

can also write your own application to update variables. 

For more information, see the Alpha® Sign 
Communications Protocol manual. 

 

Real-time data example 
 

Create sign memory configurations using Site Manager  

1. In Site Manager, double-click the site for the sign which will use 
string variables. Then click the Advanced tab. 
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2. Create a sign memory configuration by checking either: 
 

• Assign Fixed Memory Partitions — Check this to assign your 

own sign memory configuration in the Configuration box. 

(For detailed information, see the Memory Configuration 

examples in “Appendix G: Protocol Examples” of the 

Alpha® Sign Communications Protocol manual.) 
 

• Strings “A” - “Z”, Strings “a” - “z”, Strings “1” - “9” —  
Check one, two, or all three of these to create a sign memory 

configuration in the Configuration box. For example, 

checking Strings “A” - “Z” would set up 26 string files names 

“A” through “Z”. These files could then be used by the 

Alpha® String Update Control. (Checking Strings “a” - “z” 

would set up an additional 26 strings, and checking Strings 

“1” - “9” would add another 9 strings.) 
 
 
 
 
 
 

Check Assign Fixed Memory Partitions  
 

or 
 

Check one, two, or all of these 
 
 
 
 
 
 

 

Create a message with a string variable using Message Editor 
 

3. In Message Editor, create a new message by selecting File>New: 
 
 
 
 
 
 
 

4. Type Today’s sales total: 

 
 
 
 
 
 
 
 
 
 
 
 

 



How to use real-time data in a message 

 

5.  Select Options>String to insert a string variable into the message: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The string label value is determined 

by what you selected in step 2. For 

example, if you selected Strings “1” - 

“9”, then type a number from 1 to 9. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The string 

variable icon. 

 
Update the string variable using the ActiveX® control 
 

6. Use the Alpha® String Update Control (the ActiveX® component 
of AlphaNET™ 3.0 software) to update the message’s string variable. 

 
Following is a description of the available methods and properties of this 

ActiveX® control: 
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How to use real-time data in a message 
 
 
 

 
Table 18: Alpha® String Update Control Methods & Properties 

 
  METHODS 

 

    

    

 Syntax: AlphaStringUpdateCtrl.Initialize 
 

    

 Parameters: none 
 

    

Initialize  Method must be called prior to calling any 
 

 
Remarks: 

other method of this control. This method 
 

 
opens a COM port or creates a socket  

  
 

  connection to the display. 
 

    

 
Syntax: 

AlphaStringUpdateCtrl.UpdateString(“String 
 

 
Label”, Value, Color, Flash)  

  
 

    

  •  String Label — String. One character only. 
 

  (In the previous example, the String Label is 
 

  1.) 
 

 
Parameters: 

•  Value — String. This is the value to be 
 

 
passed and displayed.  

UpdateString 
 

 

 •  Color — Integer. 1 = Red, 2 = Green, 3 = 
 

  Amber. 
 

  •  Flash — Byte. 0 = off, 1 = on. 
 

    

  This method will pass any value to the 
 

  designated string. The Color parameter will 
 

 Remarks: override any color definition set by the 
 

  message itself. The Flash parameter will only 
 

  work in the Hold mode. 
 

    

 
  PROPERTIES 

 

     

ConnectMode 
Type:  Byte 

 

    

Values: 
 

0 = Serial connection, 1 = TCP/IP connection 
 

  
 

     

 Type:  String 
 

NetworkAddress 
    

Values: 
 TCP/IP address of the network adapter. (Only 

 

  
applicable to a TCP/IP connection.)  

   
 

     

NetworkPort 
Type:  Integer 

 

    

Values: 
 

3001 (default) 
 

  
 

     

 Type:  Integer 
 

     

SerialBaudRate   110, 300, 600, 1200, 4800, 9600, 14400, 
 

Values: 
 

19200, 28800, 38400, 56000, 115200, 
 

  
 

   128000, 256000 
 

     

SerialComPort 
Type:  Byte 

 

    

Values: 
 

1 through 16 
 

  
 

     

SerialDataBits 
Type:  Byte 

 

    

Values: 
 

4 through 8 
 

  
 

     

SerialParity: 
Type:  String 

 

    

Values: 
 

None, Even, Odd, Mark, Space 
 

  
 

     

SerialStopBits 
Type:  Byte 

 

    

Values: 
 

1 or 2 
 

  
 

     

Serial Address 
Type:  Integer (use 2 digits) 

 

    

Values: 
 

00 (default) 
 

  
 

     

 
 

 



How to create and use a custom automode sequence 
 
 

How to create and use a custom automode sequence 

 
The message mode called Automode is the default mode used if no other 

mode is selected in a message. It displays the message with all the other 

modes provided with AlphaNET™ 3.0 software. (For descriptions of the 

modes, see “Appendix B — Modes available on signs” on  
page 137.) 

 
A custom automode sequence can be created for each sign site. You 

can set what modes automode will use by doing the following: 
 

Creating or editing an Automode sequence  

1. In Site Manager, choose Edit>Automode File: 
 
 
 
 
 
 
 
 
 
 

2. Accept the name of default.aut for the file, choose an existing file  
if there is one, or type in a different name for a new file to use. 

Then click Open. 
 
 
 
 
 
 
 
 
 
 
 

 

3. Click Add. Then select the Interlock > OK to add the Interlock 
mode to our custom automode sequence: 
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How to create and use a custom automode sequence 

 

4. To add another mode to our custom automode sequence, click Add 
again. Then select another mode and click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

NOTE: The order of the modes can be changed using Move. Modes 

can also be added or deleted using Add and Delete. 

 

Using a custom Automode sequence 
 

1. Using Site Editor, double-click the site that is to have the custom 
automode. Select the Site Info tab and choose Alpha 2.0 for  
Compatibility. 
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N O T E 
 
To revert back to the 

default automode setting, 

click Automode File, click  
None, and then click OK. 

How to create and use a custom automode sequence 

 

2. Select the Sign Info tab. Then click Automode File and select a 
custom automode file: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Messages sent to this 

site will now use this 

custom automode. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Select OK. 
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