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iv NOTES

 

NOTES

 

The following is a list of idiosyncrasies for 

 

Gateway Messaging

 

 

 

Software

 

:

1. Conflicts with Labview V5.0: The 

 

Gateway Messaging Software

 

 will 
not run when installed on a PC that has 

 

Labview V 5.0

 

 or earlier. 
If you have 

 

Labview V 5.0

 

 or earlier, contact Adaptive Mico 
Systems for assistance.

2. Time Formats: The Gateway Messaging Software will not change 
the time format (24hr. vs. AM/PM) on a sign. The time format 
can, however, be changed at the sign using the infrared Remote 
Control. For further information on the Remote Control, see 
“Example 11 – Using the Remote Control” on page 44.”

3. Blank Messages: If a message is accidentally triggered that 
contains no variables or data, the sign will go blank. Always 
verify that your messages contain either variables, data, or both 
before transmitting the message to the sign.

4. Creating Variables: A decimal point cannot be used in variable 
data. For more information on variables, see “Example 10 — 
Creating and inserting variables” on page 40”.

5. Program names in Widows Start menu: When the Gateway 
Messaging Software is installed, several shortcuts are created on 
the Start menu. There is inconsistency between the Start menu 
name and the software/documentation:

 

Name in the
Windows Start menu

Software/documentation name

 

Profibus PD3000 Configuration Software

Modbus Plus MD3000 Configuration Software

DeviceNet DN3000 Configuration Software
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General information

 

Purpose of the system

 

A PLC Gateway system connects PLCs with ALPHA 4000 and 7000 
series signs having the Industrial Gateway upgrade. It provides the 
ability to display user-defined real-time messages. The 

 

Gateway Messaging 
Software

 

 allows you to create and edit the messages on a computer and 
download them as a group to the ALPHA signs. Messages can then be 
displayed on the signs when triggered by PLCs via the Gateway device 
(PD3000, MD3000, or DN3000.)
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System setup

 

The following are the general steps to setting up hardware, and 
generating, transmitting, and triggering messages on signs. This manual 
describes Step 3 and Steps 4a and 4b below in detail.

 

Step Description

 

1

Connect the hardware as shown here (before using the 

 

Gateway Messaging Software

 

 to create and send 
messages.)

2

Program the Gateway device using the installation document for your Gateway device. See the table 
below.

3
Create, edit, and preview messages on the PC using the 

 

Gateway Messaging Software

 

.
(Please refer to “Basic messaging” on page 10 and “Advanced messaging” on page 32 for more 
information.)

4a

 

NOTE: Perform this step (4a) whenever all the signs to receive messages in the sign network are 
connected to the computer via the Gateway device.

 

Transmit messages to signs as shown in the configuration in Step 1. If more than one sign is networked, 
all signs will receive the messages. (Please refer to “Example 1 — Creating a simple message” on 
page 10 for more information.)

1

ON

2 3 4

STATUS

2 3

PROFIBUS

SERIES

+
–

Gateway
deviceComputer with

Gateway Messaging Software
and

Gateway configuration software

Port 2

Port 3

Table 1: Supporting documentation

Part Number Title

9703-7002 How to connect ALPHA signs to Profibus DP using the PD 3000

9703-7003 How to connect ALPHA signs to DeviceNet using the DN3000

9703-7005 How to connect ALPHA signs to Modbus Plus using the MD 3000
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4b

 

NOTE: Perform this step (4b) only if a sign is added to the sign network after the initial setup.

 

Connect the sign to the industrial sign network. Using a Remote Control, transmit the messages from one 
of the signs in the sign network to the newly-connected sign.
(Refer to “Example 11 – Using the Remote Control” on page 44 for more instructions.) 

5 (Optional) If desired, disconnect the computer from the Gateway/sign network.

6
Program the PLC(s).
(Please refer to the documentation for your specific PLC(s) for more detailed information.)

7

 

NOTE: The Gateway Device must be connected to the system before performing this step.

 

Trigger messages using PLC(s) as shown here.
(Please refer to the documentation for your specific PLC(s) for more detailed information.)

 

Step Description

RS485
Gateway

PLC

RS485Industrial
PLC

Motors, switches,
relays, etc. Network

ALPHA sign(s)Gateway with Gateway firmware
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Basic software setup

 

File usage

 

The 

 

Gateway Messaging Software

 

 uses a file to hold a set of messages to 
be sent to signs. Typically, there is only one file for all messages, but you 
can create files of different messages based on varying circumstances if 
you wish. Each file has a user-defined name. When a file is downloaded 
to ALPHA signs, all messages in that file are downloaded to any attached 
sign(s.)

By default, each file is stored in the root directory of the computer. If 
you change the location when you save a file, the 

 

Gateway Messaging 
Software

 

 will remember that location and select it whenever you want to 
save again.
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Screen layout reference

 

Whenever you start the 

 

Gateway Messaging Software

 

, your computer 
screen will appear as shown here. Refer to the table below for 
descriptions.

NOTE: Items or features that are grayed out in the software are 
not available in the software.

 

 

 

Item Name Description

 

A
Message area Area for message text, variables, etc., as well as controls for the 

message and its contents.

B
Message Control button Opens a window for message options such as: position on the sign, 

display mode, delay, and justification.

C
Text Control button Opens a window for text options such as: font, color, width, and 

flashing.

D Insert Object button Opens a window for options to insert date or time.

A

B

C

D

E

F

G

J

K

L

M

N

HI
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E Insert Variable button Opens a window for options to insert a variable.

F Preview Message button Allows you to send the current message to the sign.

G
Message statistics Indicates the current message number and the maximum number of 

messages. (See “Setting message size and maximum messages” on 
page 8.)

H
Column number Indicates the column number where the cursor is positioned in the 

current message.

I Proprietary information Indicates copyright information, version, and name of the software.

J
Down button Advances the set of five messages shown in the window to the next set 

of five messages.

K
Goto button Allows you to select a specific message number to start the set of five 

messages shown in the window.

L
Up button Advances the set of five messages shown in the window to the 

previous set of five messages.

M
Priority number Indicates the priority of that message, 1, 2 or 3 (1 = low, 2 = medium, 

and 3 = high).

N Message number Indicates the number of the message.

 

Item Name Description
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Setting the serial port

 

You need to identify which serial port will be used to download 
messages from your computer to any sign(s). 

 

Step Description

 

1

In the 

 

Gateway Messaging Editor

 

, choose 

 

Tools > Setup > Serial Port

 

. Select the appropriate serial port for 
your computer.

A check indicates the 
currently-selected 
serial COM port.

When you change the 
COM port selection, 
that setting is saved 
automatically.
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Setting message size and maximum messages

 

Determining the number of characters available to use

 

Your ALPHA sign with the Gateway upgrade has 256K memory. You 
can specify how much of that memory to allocate for each message. The 
default message size is 100 bytes. You can change that to any size as 
needed. The range for message size is 50 to 450. The range for maximum 
number of available user-defined messages is 444 to 4000. (Signs can only 
accept up to 4000 messages maximum.)

NOTE: If the message size is set too small, messages may not be 
sent to the sign.

 

Step Description

 

1

Choose 

 

Modules > Setup > Message Size.

 

 Set the value as desired.

2

Determine the number of bytes taken for sending controls: add up the maximum bytes for each of the 
following if you use them in a message. Some examples are listed below.

Message controls, maximum = 6 bytes

Text controls, maximum = 10 bytes

Object controls, maximum = 3 bytes

Variable controls, maximum = 9 bytes

So, if you use all of the above once in a message, the total maximum size used for sending controls is 28 
bytes. Likewise, if you only use one set of message controls and one set of text controls, the total 
maximum size used for sending controls is 16 bytes.

3

Calculate the number of characters available to use in a message
Message size set in Step 1 above

– the number you calculated in Step 2 above

= the number of alphanumeric characters available to use in a message

This is the value, in 
decimal, for the 
size to be allocated 
for each message; 
which includes text 
and all attributes.
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Determining the number of messages available to use

 

The formula for the maximum number of messages is: 

 

200,000 / Message size = Maximum number of user-defined messages

 

Example 1:

 

The default message size is 100, therefore:

200,000 / 100 = 2000

 

Example 2:

 

If you change the message size to 50 bytes, you can create 
twice the number of messages as if you had left it at the 
default of 100 bytes.

200,000 / 50 = 4000

 

Example 3:

 

If you change the message size to 200 bytes, you can only 
create half the number of messages as if you had left it at 
the default of 100 bytes.

200,000 / 200 = 1000

NOTE: You cannot use any message number greater than the 
maximum number of messages as calculated above, even 
though you can access them in the 

 

Gateway Messaging

 

 

 

Software

 

. Doing so either will cause erratic and incorrect 
results on the sign, or those messages will not show on 
the sign.

NOTE: The table below shows the usage of the set of 

 

Gateway

 

 

 

Messaging Software

 

 messages. It indicates that, while the 
total number of system messages is 4100, you can only 
use those in the 0 to 4000 range plus the background 
message (4095.) Message 4095 is reserved for the 
background message, regardless of the maximum 
number of messages. (See “Example 8 — Setting the 
background message” on page 32 for use of the 
background message.)

 

Table 2: Usage of messages

 

Start message End message Usage

 

1 4000 User-defined messages

4001 4094 Not used

4095 4095 Background message

4096 4100 Not used
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Basic messaging

 

Example 1 — Creating a simple message

 

NOTE: Be sure your hardware is set up as in Step 1 of “System 
setup” on page 2.

This example shows how to create a simple message and display it on 
a sign.

The basic format of any message is:

 

[message controls]{text controls} message body

 

At least one set of message controls and one set of text controls are 
required. The basic format may be repeated as many times as necessary. 

 

Specify how to show the message on a sign.

 

The 

 

message controls

 

 determine certain settings for the entire message. 
This example introduces the 

 

message control 

 

defaults. 

 

Step Description

 

2

Place the cursor at the start of the first message.

Message controls 
are placed at the 
start of any message.
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3

Click on the 

 

Message Control

 

 button. The 

 

Message Control…

 

 window will appear. For now, leave the 
settings as they are. Click 

 

OK

 

.

4

The message will look like this, with the

 

 message controls

 

 inserted within brackets, [].

 

Step Description

Position 
Top: Places a message on the top 
line of a sign, or above a prior 
message for the bottom of the 
sign.
Bottom: Places a message on the 
bottom line of a sign, or below a 
prior message for the top of the 
sign.
Middle: Places a message in the 
middle of the sign, regardless of 
the number of lines available.
Fill: Uses all lines on a sign for 
the message.

Mode
Hold: Holds the message in one 
place on the sign.
Rotate Left: Rotates a message 
from the right to the left 
horizontally across a sign.

These are the defaults for the message controls the first time you 
use the Gateway Messaging Software. After the first time, the 
controls are set as you used them the last time in a message.

Display Message
0 to 5 seconds: Refreshes and 
redisplays the message after the 
number of seconds specified.

Justification
Center: Aligns the message 
in the center of the sign.
Left: Aligns the message on 
the left side of the sign.

Message controls that will 
be inserted and used in the 
message are automatically 
shown in this display box.

NOTE
If message 
controls are 
not set in a 
message, they 
default to 
those of the 
prior message 
in the sign.
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Now we will add the Text Controls. Text Controls determine settings 
for how the message text will appear on the sign (font, color, width, and 
flashing).

 

Step Description

 

5

Place the cursor at the end of this message, after the 

 

message controls.

 

 

 

6

Click on the 

 

Text Control

 

 button. The 

 

Text Control…

 

 window will appear. 

The text controls are placed 
after the message controls 
and anywhere thereafter 
when you want to change 
the look of the text.

You must put message 
controls at the beginning 
of the message to properly 
send the message to the 
sign.

Font
5, 7, 10, or 16 pixel high: 
Indicates the maximum 
number of pixels to use for the 
height of characters. Font is 
sans-serif.
Fancy 7-or 16 pixel high: 
Indicates the maximum 
number of pixels to use for the 
height of characters. Font is 
serif.

Color
Choose red, green, or yellow.

These are the defaults for the text controls the first time you use 
the Gateway Messaging Software. After the first time, the controls 
are set as you used them the last time in a message.

Width
Standard: Uses normal width 
characters.
Wide: Number of pixels = 
Standard + 1.
Double Wide: Number of 
pixels = Standard x 2.

Flash
On: Turns flashing on for the text 
following the control, until 
changed by another Flash control.
Off: Turns flashing off for the text 
following the control, until 
changed by another Flash control.Control Code 

Not available.

Text controls are 
applied to the text 
when that attribute 
box is checked. See 
the next step. 

Text controls that will be 
inserted and used in the 
message are shown in this 
display box.
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7

For now, leave the choices as they are, but use the check boxes to turn on

 

 Font, Color, and Width.

 

Click

 

 OK.

 

8

The message will look like this, with the 

 

text controls 

 

inserted within braces, {}. 

 

Step Description

Text controls are 
applied to the text 
only when that 
attribute is checked.

Text controls that will 
be applied are 
automatically shown 
in this display box.
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Enter text. 

Save the message file. 

 

In this section, we will save the message that you just created.

NOTE: You can choose a different sub-directory for your files. 
The one shown below is for exemplary purposes only.

 

Step Description

 

1

Place the cursor in the 

 

Message area

 

 for the first message and type a message. Text in a message will be 
shown in red when the cursor is in that message. 

 

Step Description

 

9

Choose 

 

File > Save.

 

 For a new file, you’ll see the 

 

Save As…

 

 window.

 

 

When the cursor is placed 
in a message, that 
message is “selected” and 
the contents of the 
message are shown in red.

NOTE: Do not use a 
colon in a message. 
See “Appendix B: 
Frequently-Asked 
Questions” on page 52.
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Download messages 

In order for your messages to be displayed on the sign, you must 
download them to the sign. Once this is complete, the message order will 
depend upon the priority level that you set each message to. For further 
information about the message priority level, see “Example 3 — Setting 
message priorities” on page 19.

NOTE: Before downloading messages, be sure that all the 
hardware is properly connected as shown in “System 
setup” on page 2.

10

Fill in the name of the file that you want to use. You don’t need to provide the extension. “ims” will be 
used as the default. Choose Save. 

Step Description
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Step Description

11

Choose Modules > ModBus > Download Messages. All valid messages in the file will be transmitted to 
the attached sign.
When the download is finished, click OK to close that window.
All the messages downloaded to the sign will be displayed on the sign, and then “No Background 
Message” will appear on your sign. The message queue will now be cleared.

Each message will be 
listed as it’s transferred.

The message size is 
shown in hexadecimal. 
0064(H) is the same as 
100 bytes in decimal.

Wait until you get this 
notification.

This indicates that the 
message queue is 
cleared.
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Example 2 — Making a message flash
You can make portions, or all, of a message flash on and off.

Step Description

1

This example will show how to make the first message flash. 

2

First, highlight the text controls that are in the message currently.

3

Delete these text controls (with the Delete or Backspace key).
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4

Click on the Text Controls button. Select and check the same options were in the message before, and 
also select and check Flash > Enable. 

5

All the selected options, including Flash will be included in the message.

6

This message shows how to make the first part of a message flash, while the second part does not.

Step Description

NOTE: It’s a good idea to be sure to turn Flash off 
where you want it to stop. Otherwise, the next 
message will assume the Flash Mode also.
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Example 3 — Setting message priorities
The message priority specifies the importance of a message. 

Messages of a lower priority will not run if any message of a higher 
priority is running. 

The next two tables illustrate sample messages with various 
priorities, and the results of sending those messages to a sign in various 
combinations. (For a more elaborate example, showing activation and 
deactivation registers for the PLC, see “Appendix A: Sending priority 
messages from a PLC” on page 50.)

The table below shows the results of sending sample priority 
messages. (For a more elaborate example, showing activation and 
deactivation registers for the PLC, see “Appendix A: Sending priority 
messages from a PLC” on page 50.)

Step Description

1

Use the up/down arrows for each message to set its message priority. 

Table 3: Sample priority messages

Message number Priority Level

1 Low = 1

2 Low = 1

3 Medium = 2

4 High = 3

5 High = 3
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Table 4: Results of sending sample priority messages

Message queue
Message number 

of message 
displayed on sign

Highest priority 
message 
displayed

1 1 Low

1, 2 1, 2 Low

1, 2, 3 3 Medium

1, 2, 3, 5 5 High

1, 2, 3, 5, 4 5, 4 High

2, 3, 5, 4 5, 4 High

2, 3, 5, 4 5, 4 High

2, 3, 5 5 High

2, 3 3 Medium

2 2 Low

– – Background message
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Example 4 — Deleting messages
You can delete the contents of any one message or delete the entire set 

of messages already downloaded to a sign by: 

• Highlighting the message, and then pressing the backspace key on your computer.
• Completing steps 1-4 as shown below.

NOTE: There is no “Undo” capability in the Gateway Messaging 
Software. Once a message is deleted from a file or a set of 
messages is deleted from a sign, you can’t get it back 
without recreating it!

Deleting the contents of a message 

Description

1

Place the cursor anywhere in the Message area for the message to be deleted. 

2

From the menu bar, choose Edit > Clear Message. Everything in that message will be deleted.
NOTE 1: There is no “Undo” capability in the Gateway Messaging Software. Once a message is deleted 
from a file, you can’t get it back without recreating it! 
NOTE 2: See question 1 in “Appendix B: Frequently-Asked Questions” on page 52 for an understanding 
of what happens when this file of messages is downloaded to a sign.
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Deleting all messages on a sign 

NOTE: Before deleting messages, be sure that all the hardware is 
properly connected as shown in “System setup” on 
page 2.

Step Description

1

Choose Tools > Clear Sign Memory. 

2

The Memory… prompt will ask for confirmation. Choose Send to send the command to delete all 
messages from the sign. NOTE: There is no “Undo” capability in the Gateway Messaging Software. Once 
a set of messages is deleted from a sign, you can’t get it back without recreating it! 

3

You will receive a notification that the command was transmitted. All signs connected to the PC will 
receive the transmission and will be cleared.

NOTE: This notification 
does not indicate that the 
sign actually received the 
command. It simply 
means that the command 
was sent.
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4

Once this is complete, the following messages will appear on your sign:

Step Description

NOTE: These messages on 
the sign means that the 
command was received 
and processed by the sign.

NO BACKGROUND MESSAGE

No Network Activity
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Example 5 — Checking message syntax
“Syntax” refers to the construction of words, phrases, sentences, or 
messages according to established rules. The construction must be 
correct for a message to be displayed correctly. The Gateway 
Messaging Editor can check the syntax of messages for you. Follow the 
steps to determine and fix any errors.

Basic syntax check example

Step Description

1

As an example, say you accidentally entered text controls twice, as shown here, with one set of controls 
embedded in another. 

2

Choose Tools > Message Syntax Check. The syntax check will start automatically. All messages in the file 
will be checked. There is a status bar at the bottom of the window.    

Status bar
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3

The Message Syntax Check processing indicates the message number, the starting position in the 
message of any syntax error, and when the process is complete. Choose OK when the process is done. 

4

Place the cursor in the message where indicated by the column number and message statistics.   

5

Determine and correct the error, in this case, by selecting and deleting the extraneous text. 

Step Description

NOTE: Only 
messages with 
errors will be 
shown.

This number indicates that 
this error is in the brace.

error
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Advanced syntax check example

An advanced syntax error is an error that appears somewhere other 
than in the brackets, or braces. However, during the Message Syntax Check, 
the error will still be shown in the beginning position of where the error is 
located. Shown below is this error.

Step Description

1

As another example, say you again accidentally entered text controls twice, but this time with the wrong 
set of controls embedded at the end of the other. 

2

Choose Tools > Message Syntax Check. The Message Syntax Check processing indicates the same 
starting position for the syntax error as in the example above. 

3

Determine and correct the error, again by selecting and deleting the extraneous text. 
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Example 6 — Previewing the message
While you are developing a message, if you want to see how it will 

actually look, you can use the Preview function to display the message on 
a sign.

Step Description

1

The sign to be used for previewing must be connected to the PC.

2

In the Gateway Messaging Software, with the cursor in the message to be previewed, choose the Preview 
Message button. 

1

ON

2 3 4

STATUS

2 3

PROFIBUS

SERIES

+
–

RS485 Gateway
deviceComputer with

Gateway Messaging Software
and

Gateway configuration software

Port 2

Port 3
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3

This window will appear to confirm that you really want to send the current message to a sign for preview. 
Click on the Send button. 

4

When the message is sent to the sign, you receive this notice. The message is displayed directly on the 
sign. Click Cancel to close this window.

5
If the message does not look the way you want it, make your changes and repeat Steps 2 through 4 as 
needed.

Step Description
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After you have previewed the message(s), and assuming that you 
want to use these messages, download all messages to the sign and 
reconnect the sign to the network as explained below:

Step Description

4

Download all messages to the sign: Choose Modules > ModBus > Download Messages. 
When the download is finished, click OK to close that window.

Each message will be 
listed as it’s transferred.

The message size is 
shown in hexadecimal. 
0064(H) is the same as 
100 bytes in decimal.

Wait until you get this 
notification.

This indicates that the 
message queue is 
cleared.
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Example 7 — Sending messages to a sign on an
operating PLC network

If you are sending any messages to the sign, whether previewing or 
downloading messages, it is strongly recommended that the PLC 
network be offline. However, if this is not possible, follow these 
examples.

Previewing a message on a sign while the PLC network is running

This example shows how to preview a message on a sign while it is 
connected to an operating PLC network.

Step Description

1

Place your cursor in the message to be triggered by the PLC. The message text will turn red to indicate 
that the message is active.

2

Click on the Preview Message button to preview the message on the sign. The message will appear on the 
sign.
NOTE: “System on” and another message might be running at the same time.

3

If the sign does not return to normal running operation after previewing the message, complete one of the 
following two options:

0. Unplug the sign from the network for at least 3 seconds.
A. Download all messages to the sign again. For further information, see “Downloading 

messages to a sign while the PLC network is running” on page 31.

Message which is red indicates that this is the 
message that will be previewed on the sign.

Preview Message button



Gateway Messaging Software Manual

Basic messaging 31

Downloading messages to a sign while the PLC network is running

This example shows how to download messages to a sign while it is 
connected to an operating PLC network.

Step Description

1

After you have completed your messages, select Modules > Modbus > Download. 

2

All messages are downloaded to the sign.

3
The sign will display the downloaded messages, scrolling through each one sequentially. While this is 
happening, all PLC operation to the sign is interrupted.

4

After the message queue is cleared, both the sign and the PLC network return to normal running operation.

Each message will 
be listed as it’s 
transmitted.

Wait until you get 
this notification.

This indicates that the 
message queue is cleared.

NO BACKGROUND MESSAGE

No Network Activity

One of these two messages 
might appear briefly on your 
sign once all the active 
messages have been 
downloaded into the sign.
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Advanced messaging
Before attempting the following, make sure you’re familiar with the 

previous examples in the “Basic messaging” section of this manual.

Example 8 — Setting the background message
The background message is designed to be run on a sign when there 

is network activity but none for that particular sign, and no other 
messages are already running on that particular sign. In this case, the 
background message will be displayed on a sign. Using the background 
message is recommended. If you don’t use it, the sign will display “No 
Background Message”. You can use the background message to display 
messages such as a welcome to the company, an inspirational thought, or 
the date or time. 

Step Description

1

Choose Edit > Background Message. 
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2

This window for the background message will appear. 

3

Type your message and use the buttons as needed. Click on OK to close this screen.

Step Description
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4

You can also go directly to message 4095, the designated message number for the background message, 
to make your changes by clicking on the GoTo Button. 

This screen will appear:

5
Type in the number of the message that you wish to review, in this case 4095. Click on the OK button. 
You will be taken to that message.

6 Click inside Message #4095 to activate that message. 

7 Click on the Preview Message button to preview the Background Message on the sign.

8 Click Send to complete the message previewing process.

Step Description

GoTo Button
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Example 9 — Using time or date
You can synchronize the sign’s time and date to those of the 

computer so that time or date included in a message will be accurate. You 
can also include time and/or date in a message. The two examples that 
follow demonstrate these functions.

Setting the sign’s date and time 

This example shows how to send the computer’s date and time to an 
attached sign. 

NOTE: You can also set a sign’s date and time directly using the 
hand-held Remote Control. (Please refer to “Using the 
Remote Control with a sign” on page 45, for more 
information.) However, if the date and time are set this 
way, they will not be synchronized with either the 
computer or with other signs. 

NOTE: You must reset the time to accommodate Daylight 
Savings Time. 

Step Description

1

Choose Tools > Send Date or Tools > Send Time. 

2

You will be receive one of these prompts. Choose the Send button.   
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Adding date to a message 

3

You will be notified of the transmission status. After this, any message with time or date will be updated 
with the correct values. 

4
You can verify that the date and/or time on the sign is correct by checking the sign itself using the hand-
held Remote Control. (Please refer to “Using the Remote Control with a sign” on page 45, for more 
information.)

Step Description

1

Type text in a message, such as “Today’s date is: ”. Then click the Insert Object button. 

Step Description

NOTE: This notification does not 
indicate that the sign actually 
received the command. It simply 
means the command was sent.
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2

Choose a format for the date from the drop down list.   

3

Check the Date checkbox. Click OK.

4

The date format is inserted in the message and will be supplied from the sign’s date at message run time. 

Step Description

NOTE: You can insert 
only one object at a 
time. Therefore, only 
one checkbox can be 
checked at a time. 

Animation and 
Miscellaneous 
are not available.

date format
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Adding time to a message 

Step Description

1

Click on the Message Control button and select the following attributes:
• Position: Top
• Mode: Hold
• Message Pause: 3 Sec
• Justification: Center

Click on the Text Control button and select the following attributes:
• Font: 5 Pixel high
• Color: Green
• Width: Standard

Type text in a message, such as The time is:. Then click the Insert Object button.

2

Choose a format for the time from the drop-down list. Here, we are changing from the current setting of 
24-hour format to the new setting of am/pm format. 

Insert Object button
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3

Check the Time checkbox. Click OK. 

4

The time format is inserted in the message and will be supplied from the sign’s time at message run time. 

Step Description

NOTE: You can insert 
only one object at a 
time. Therefore, only 
one checkbox can be 
checked at a time.
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Example 10 — Creating and inserting variables
This example shows how to create and insert the values of real-time 

data in a PLC, such as sensors, RTD’s etc.) into messages on signs. 

Step Description

1

Enter the following Message Control attributes:
• Position: Top
• Mode: Hold
• Message Pause: 4 sec.
• Justification: Center

Enter the following Text Control attributes:
• Font: 5 Pixel high
• Color: Yellow
• Width: Standard

Type text, such as Vat temperature=, in a message. Then click the Insert Variable button. 

Insert Variable button
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2

This window will appear.    

Step Description

Variable Number
Specify a unique number 
(1-100) for the variable. 
Must be the same as the 
number in the PLC.

Variable Name
Specify any unique name 
for the variable.

Type
Not available.

Format
No Padding: Does not insert any leading characters in front of the variable in the message.
Leading 0: Inserts the appropriate number of zeros in front of the variable in a message to fill the 
complete size allocated for the variable.
Leading Space: Inserts the appropriate number of spaces in front of the variable in a message to 
fill the complete size allocated for the variable.
+/– No Padding: Does not insert any leading characters in front of the variable in the message. 
Includes positive and negative denotation.
+/– Leading 0: Inserts the appropriate number of zeros in front of the variable in a message to fill 
the complete size allocated for the variable. Includes positive and negative denotation.
+/– Leading Space: Inserts the appropriate number of spaces in front of the variable in a message 
to fill the complete size allocated for the variable. Includes positive and negative denotation.

Size/width
Not available.

Variable controls
Show the specifications for 
the variable as they will 
appear in the message.

NOTE: Default for Variables is 1 and No Padding.

NOTE: Left justifications is recommended for using variables in a message.
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3

Type in the name of the variable. Click OK. 

4

The variable will be inserted into the message. 

Step Description

NOTE: Do not skip this step. Otherwise, the variable will not 
reach the sign.

Variable
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5

(Optional) This window shows how similar messages, with different text controls, can be used and 
triggered under differing circumstances. Notice that the only difference between the messages is the text 
color. 

Step Description

When Vat Two temperature is… Its PLC will be set to trigger…

less than 190° C Message 1

between 190° C and 200° C Message 2

greater than 200° C Message 3

NOTE: After the variable name is created, and you change the name of 
the variable, you must change all the variables in the program 
file, otherwise, each message will be a reflection of the variable 
that you recently changed.
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Example 11 – Using the Remote Control
A Remote Control can be used for the following functions on your 
sign:

• Turning a sign on/off
• Setting the sign’s serial address
• Setting the Time and Day/Date in a sign
• Clearing the Message Activation
• Clearing the sign’s memory 
• Special + D option (Transfers one sign’s memory to another sign’s memory.)

Remote Control description
A Remote Control is a hand-held keyboard used to operate an 

ALPHA sign. From its front, a Remote Control emits infrared light which 
can control many of the functions of an ALPHA sign. 

A Remote Control needs four AAA batteries to operate.

Y Z

S T U V W X

M N P Q RO

G H I J K L

A B C D E F

1 2 3 4 5 6

7 8 9 0

AUTO SPEED TIME DOT

ROLL WIPE SCROLL FLASH HOLD ROTATE

APPEND CURSOR SPECIAL FONT WIDTH COLOR

ON - OFF

REMOTE CONTROL

SOUND

INSERT BACK ADV DELETE

# ¢ $ % & *

< > = / + -

; : , .

? !

PROGRAM RUN

SELECT

SPACE RETURN

SHIFT CAPS SHIFT

Figure 1: Infrared (IR) Remote Control keyboard

Press PROGRAM to put 
the sign into 
programming mode. 
(This mode is used to 
set the date and time, 
type in messages, etc.)

Press RUN twice to 
exit programming 
mode.

To turn the sign off or 
on, hold down SHIFT 
and then press 
PROGRAM.

Point this end of the Remote Control at a sign.
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Using the Remote Control with a sign
To program a sign with a Remote Control:
• Stand at least 5 feet and no more than 30 feet from the sign. 
• Make sure nothing reflective is in front of the sign. (Light from 

the sign’s display that is reflected back can interfere with the 
Remote Control.)

• If nearby fluorescent lights interfere with the Remote Control, 
you may have to relocate either the lights or the sign.

NOTE: Once the Gateway is connected to a sign, you will no 
longer be able to use your Remote Control.

Turning a sign on/off

When you plug in the sign’s power supply, the sign starts up 
automatically, and unplugging the power supply turns the sign off.

However, instead of unplugging a sign, there is another way to turn a 
sign off: Using the Remote Control, hold down SHIFT and then press 
PROGRAM to turn a sign off and on.

If a sign is this far from the floor... ...then hold a Remote Control
this far away:

10 feet from 10 to 30 feet

15 feet from 19 to 30 feet

20 feet from 25 to 30 feet
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Setting a sign’s serial address

The serial address is a number that you can assign to a sign. 
Typically, this feature is used for a sign that is connected to other signs on 
a network. Giving a unique serial address to a sign allows you to send 
messages to that particular sign.

See the document Network Configurations (part number 9708-8046) 
for more detailed information on networking signs.

Step When you do this... You see this...

1
Press PROGRAM. SET SERIAL ADDRESS will 
appear on your sign.

2 Press ADV.

3

Type a number, like 100.

NOTE: A serial address is actually a number 
from 1 to 255 in hexadecimal (01 to 
FFh).

4 Press RUN twice to set the new serial address and return the sign to normal operation.

SET SERIAL
ADDRESS

SERIAL ADDRESS = 001

SERIAL ADDRESS = 100
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Setting the Time and Day/Date in a message

Once set, a sign will remember the time and date unless the sign is 
unplugged or interrupted by a power loss. 

NOTE: If a sign is unplugged or interrupted by a power failure, 
you will have to manually reprogram each sign.

To set the time and date into a message, complete the following steps 
using a Remote Control.

1. Press PROGRAM.

2. Press BACK until SET TIME AND DAY or SET TIME appears.

3. Press ADV.

4. Press D to set the day of the week.
Press H to set the hour.
Press M to set the minute.

5. Press BACK until SET DATE appears.

6. Press ADV.

7. Press D to set the day of the month.
Press M to set the month.
Press Y to set the year.

8. Press RUN twice to return the sign to normal operation.
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Clearing the Message Activation

Clear Message Activation is a way to clear the messages that you 
currently have running in the message queue. Your messages that are 
currently stored will not be lost when you do this provided the messages 
were previously downloaded to the sign, or you have previously saved 
them in your computer. (For further information on downloading your 
messages to the sign see “Example 6 — Previewing the message” on 
page 27. For further information on saving your messages in your PC, see 
“Save the message file.” on page 14.)

To clear the message activation using your Remote Control, complete 
the following:

1. Press PROGRAM on your Remote Control.

2. Press Back until “Clear Message Activation (Y/N)” appears on your 
sign.

3. Press Y.

4. Queue is cleared when “Queue Cleared” appears on the sign.

5. Press RUN to return the sign to normal operation.

Clearing the Sign’s memory

Clearing the sign’s memory is a way to completely erase all messages 
from your sign. To clear your sign’s memory, complete the following:

1. Press PROGRAM on your Remote Control.

2. Press Back until “Clear Memory” appears on your sign.

3. Press ADV on the Remote Control. A warning will appear on the 
sign’s screen.

4. Press Y to clear the sign’s memory. “Memory Cleared” will appear, 
and then “No Network Activity” will be displayed.

5. Press RUN to return the sign to normal operation.
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Special + D option: Transferring a sign’s memory from one sign to another.

You can transfer the messages from the memory of one sign to the 
memory of any another signs by completing the following steps.

NOTE: To complete the transfer of memory from one sign to other 
signs, all signs must be connected together and all must be 
set to either RS232 or RS485 jumper. For further information 
on connecting signs and the RS232 and RS485 jumper, see the 
Network Configurations Manual, p/n 9708-8046A.

1. Point the Remote Control toward the infrared receptor of the 
sending sign.

2. Press PROGRAM.

3. Press SPECIAL.

4. Press D.

5. The sending sign will transmit all messages to the receiving 
sign(s).
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Appendices

Appendix A: Sending priority messages from a PLC
The message priority specifies the importance of a message. 

Messages of a lower priority will not run if any message of a higher 
priority is running. 

The next two tables illustrate sample messages with various 
priorities, and the results of sending those messages to a sign in various 
combinations.

Step Description

1

Use the up/down arrows for each message to set its message priority. 

Table 5: Sample priority messages

Message number Priority

1 Low

2 Low

3 Low

4 Medium

5 Medium

6 Medium

7 High

8 High

9 High
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This table is used in conjunction with programming your Gateway 
device.

Table 6: Results of sending sample priority messages

Message 
number in 
Activation 
Register

Message 
number in

Deactivation 
Register

Message queue
Message number 

of message 
displayed on sign

Highest priority 
message 
displayed

1 xx 1 1 Low

2 xx 1, 2 1, 2 Low

3 xx 1, 2, 3 1, 2, 3 Low

5 xx 1, 2, 3, 5 5 Medium

4 xx 1, 2, 3, 5, 4 5, 4 Medium

6 xx 1, 2, 3, 5, 4, 6 5, 4, 6 Medium

9 xx 1, 2, 3, 5, 4, 6, 9 9 High

8 xx 1, 2, 3, 5, 4, 6, 9, 8 9, 8 High

8 1 2, 3, 5, 4, 6, 9, 8 9, 8 High

7 1 2, 3, 5, 4, 6, 9, 8, 7 9, 8, 7 High

7 5 2, 3, 4, 6, 9, 8, 7 9, 8, 7 High

xx 7 2, 3, 4, 6, 9, 8 9, 8 High

xx 9 2, 3, 4, 6, 8 8 High

xx 8 2, 3, 4, 6 4, 6 Medium

xx 4 2, 3, 6 6 Medium

xx 6 2, 3 2, 3 Low

xx 2 3 3 Low

xx 3 – – Background 
message

xx = Doesn’t matter
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Appendix B: Frequently-Asked Questions

Q1. Why were my old messages deleted when I sent new messages?
A. Downloading messages transfers all messages in the Gateway 

Messaging Editor file to a sign. If any messages had already 
been downloaded, they are replaced if there is a replacement 
message. For example:

Q2. What effect will a colon have in a message?
A. It tells the sign that whatever follows the colon or a semi-colon 

is control codes, similar to message controls or text controls. Do 
not use a colon or a semi-colon in a message!

Q3. Why does my sign show only the message “No Network Activity”?
A. There are several possible causes:

1. Network wiring fault
2. PLC fault
3. Gateway device fault
4. ALPHA sign fault
5. ALPHA sign time-out because of no network activity for at 

least 3 seconds

Q4. What’s the difference between Center Justification and Left 
Justification when I’m using the Rotate mode?

A. None. The Rotate mode starts the message on the right side of 
the sign and moves it to the left side across the sign.

Message 
number

Initial
set of messages

New
set of messages

Resulting
set of messages

1 M1A M1B M1B

2 M2A –– M2A

3 –– M3B M3B

4 M4A M4B M4B

5 M5A –– M5A

6 –– –– ––
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Q5. What are the defaults for control codes?
A. When the system is first installed and setup, they are:

After you change settings, they remain as set until you change 
them again. So, if you change the settings for Message 1, and 
then go to Message 2, the defaults will be the same settings as 
you had for Message 1.

Q6. When I downloading messages to the sign, it responds with either “No 
Background Message” or “No Network Activity”. Why aren’t the 
messages displayed?

A. Check to see what protocol is being used. Only Modbus 
protocol will work with the Gateway firmware upgrade.

A. You may be sending the information to the wrong sign. Check 
the Modbus protocol being sent to the sign or change the 
address in the sign with the hand-held Remote Control.

Q7. One of my signs only displays the “No Network Activity” message.

A. There may be a problem with the connection or wiring. 
A. The sign may be set to RS232 communications instead of RS485.
A. The Gateway may be programmed to send RS232 instead of 

RS485.
A. No information is being sent or routed to the sign.
A. Port 2 or Port 3 is configured incorrectly.

Control type Setting Default

Message Controls

Position Top

Mode Hold

Display Message Zero seconds

Justification Center

Text Controls

Font 5 pixel high

Color Red

Width Standard

Flash Enable

Control Code (none)
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Q8. My sign(s) will display the message that I want, but after a few 
seconds, the message “No Network Activity” appears.

A. The message “No Network Activity” appears when the sign 
does not see ANY network activity for 3 seconds. To correct the 
problem, you must have the PLC send some type of data to the 
display every couple of seconds. This data can be either 
messages or variable data for the sign. You could even send 
dummy variable data to one or all the signs, but be sure it’s 
variable that is not being utilized. 

Q9. One of my sign(s) only displays “No Background Message”
A. The sign detects some type of network activity, but none of the 

information is for that particular sign. This may be due to the 
wrong protocol being sent to the sign, incorrect settings in the 
Gateway, or the sign in question has never been sent 
information to trigger a message in that sign. See “Example 8 — 
Setting the background message” on page 32.

Q10. I have multiple messages being displayed on the sign when triggered 
by the PLC. How do I clear one or all of the messages?

A. You can clear the message(s) by sending the message number 
you want cleared to register 102 in the sign.

A. If you want all the messages cleared, disconnect the sign from 
the network until the “No Network Activity” message is 
displayed.

A. You can send FFFFh to register 101 in the sign. 

Q11. How do I trigger messages in the sign?
A. Send the message number you want to trigger into register 101 

in the sign. See the Gateway manual for your specific device.

Q12. How do I turn off the message(s) that I currently have displayed in the 
sign?

A. Send the message number you want to turn off to register 102 in 
the sign.

A. Send FFFFh to register 101 in the sign. 

Q13. How many messages can be displayed at one time?
A. 64. They are stored in registers 103-167, which is the message 

queue.

Q14. Can the sign read information from another device that has Modbus 
protocol?

A. No. The signs act as slaves on the network and cannot initiate 
communications.



Gateway Messaging Software Manual

Appendices 55

Q15. What are the different types of networks that I can connect up to?
A. DeviceNet

Profibus
Modbus Plus
Modbus ASCII

Q16. What ASCII formats does your sign support?
A. This table shows the two ASCII formats:

Q17. I am sending variable data to the sign, but it skips or misses data.
A. You may be sending information too quickly to the sign. Space 

out the time between transmissions to greater than 250 
milliseconds (ms).

A. Change the ‘Pause time’ in the message. 

Q18. How many variables does the sign allow?
A. 100. These are in registers 001-100 in the sign.

Q19. What if I want to add or change a message that I have downloaded to 
the sign? 

A. You can add or change a message in the Gateway Messaging 
software, then download the new information to the sign. See 
“Example 1 — Creating a simple message” on page 10.

Q20. How do I display variables on the display without them shaking?
A. Use Left-justify for the message versus Center-justify.

Q21. I downloaded my messages, and one message did not show up.
A. Your message may be longer than the message size selected. 

Check the message. Change the message size if needed.

Format 1 Format 2

Mode ASCII ASCII

Baud Rate 9600 9600

Data Bits 7 7

Parity Even Odd

Stop Bits 2 2

RTS Control None None
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Q22. I download messages to the sign and some of the message attributes 
are displayed.

A. Check the message attributes within the message. They may be 
missing a {} or []. 

Q23. How do I put the Gateway into the configuration mode for 
programming?

A. Turn its DIP switch 3 on.
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