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Installing Smart Alec software

 

For a comprehensive overview of the Smart Alec system, see 
ÒAppendix A: Smart Alec system overviewÓ on page 91.

 

Pre-installation

 

Before installing the Smart Alec software, use this ßowchart:

Does the computer
 on which Smart Alec will be
installed meet the necessary

requirements?

Do you have 
complete information

on each device
you wish to install?

Yes

Yes

Yes

Yes

Do you have 
complete information

on each Location
you wish to install?

No / Don't know

No / Don't know

No / Don't know

Have you
made a list 

of all the Users and
their passwords?

No / Don't know

Will the software
be installed on

one computer or 
multiple computers?

No / Don't know

Start

Yes

Install the software.

See “Appendix B: Smart Alec computer requirements” on page 95.

See “Appendix C: Device Driver information” on page 96.

See “Appendix D: Location properties” on page 99.

See “Appendix E: User properties” on page 111.

See “Appendix F: Network types” on page 112.
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Administrator (Server) installation

 

If you are administering a Smart Alec system, follow these 
steps to install the Server software:

1. Close all applications on your computer.
2. Insert the Smart Alec CD-ROM in your computer. The 

installation program will autostart, and this screen 
should appear:

NOTE
The Client software may also be 
installed with the Server. See 
“Appendix F: Network types” on 
page 112 for more information.
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3. If there is a version of Smart Alec already on your 
computer, the following prompt will appear:
¥ Select 

 

Yes

 

 if you want to remove an older version. 

 

After un-installation is Þnished, you will have to 
re-start the install program.

 

¥ Select 

 

No

 

 if you need to keep the previous version of 
software. Normally, there should be no need to keep 
an older software version.

4. The installer will display prompts in which you must 
accept the End-User Agreement.

5. You will be prompted whether or not to install the Smart 
Alec Server, Client, or both software:

Selecting Yes deletes all setup 
information — Users, Locations, etc. 
Make sure all this information is 
recorded before continuing.

A system administrator would 
select one of these options.

(If the Server will be installed on 
its own computer, then select 
Smart Alec Server.)
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6. Next, enter the following information:

7. The installer will attempt to locate an existing Server. If 
one is found, the installer will warn you not to install to 
that directory.

8. Select a directory for the Server:

9. After the Server components have been installed, this 
message will appear if you are also installing the Client:

To install the Server in a different 
directory or computer, use Browse.

If the Client is not being installed with 
the Server, then skip to the last step.
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10. If the Smart Alec Client is also being installed, the 
installation program will search for the Smart Alec Server 
(ALEC.EXE). If the Server is not found or if you want to 
use a different Server, locate the Server by using 

 

Browse

 

:

11. Next, you will be prompted where to place the Client:

If the installation program does not find the Server 
(ALEC.EXE), and the Server is on a network (and not on 
your PC), then you must locate and “map” the Server.

To install the Client in a different 
directory or computer, use Browse.
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12. After installation is complete, the following will appear:

13. To check if the installation was successful, look at the 

 

Start > Programs

 

 

 

> Smart Alec

 

:
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Setting up the system

 

The 

 

Administrator

 

 must be used to set up the following for 
Þrst time use:

¥ Device Drivers Ñ properties such as baud rate, comm 
port number, modem init strings must be set for devices 
such as modems, pagers, etc.

¥ Locations Ñ are message destinations created by using a 
speciÞc type of device (such as a modem, wireless. etc.) 
for each Location.

¥ Users Ñ are the system administrator and all people who 
use the Client software. For a User, the system 
administrator creates a password and decides the 
Locations, Variables, and Templates the User can access.

 

1. Set up Device Drivers

 

1. Start the 

 

Administrator

 

. A password prompt will appear:

2. The Þrst time the 

 

Administrator

 

 is started, you will be 
asked to verify these Device Driver prompts:

NOTE
Default settings are provided 
for each Device Driver which 
should be sufficient in most 
cases.

If you have not set up a Username and 
Password for yourself, select OK to continue.
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3. When the 

 

Admistrator

 

 window appears, Device Drivers 
can be changed by double clicking on the driver you 
wish to change:

 

2. Set up Locations

 

1. Start the 

 

Administrator

 

 if it is not already started:

2. To create a new Location, select 

 

File > New > Location

 

 and 
either 

 

Alpha SA

 

 or 

 

Pager

 

. Then pick the appropriate 
device for the Location:

Double click on a Device 
Driver to change it.

This indicates that 6 out of 100 
Variable licenses have been used.

This indicates that 1 out of 5 
User licenses have been used.
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3. Set the necessary parameters for the Location:

Use meaningful Location names. (For 
example, the Wired in the name tells 
you what type of device is used by 
this Location.)

These are the serial address 
numbers of signs. (Signs leave the 
factory set to address 0. Use a hand-
held Remote Control to change a 
sign’s address. See Appendix N for 
details.)

Allows you to correct for time zone 
differences. For example, if you’re 
sending messages from the Central 
Standard Time zone to a sign located 
in the Eastern Time zone (which is 1 
hour ahead), you would adjust by 1.

Send a test message to the sign to 
check for proper configuration.

A complete set of Locations might look like this:
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4. After all Locations have been created, you can organize 
them into categories (called 

 

Groups

 

) so that messages can 
be sent to a Group as well as a Location. To create a 
Group, select 

 

File > New > Group

 

:

These two Groups were 
created using the 
example Locations from 
the previous step.

The Groups and Locations 
would appear like this in 
the Administrator:
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3. Set up Users

 

1. Start the 

 

Administrator

 

 if itÕs not already started.
2. To create a new User, select 

 

File > New > User

 

:

 

NOTE:

 

To prevent unauthorized system access, the 
administrator should add a password for the default 
User 

 

alec

 

.

3. User information can be changed by simply double 
clicking on a UserÕs name in the 

 

Administrator

 

.

Enter the User’s Email Address (if any).

Enter the new User’s Login Name 
and Password.

Add the Groups, Locations, 
Variables, and Templates to which 
the User will have rights. Note that 
Variables are set up in Variable 
Manager, and Templates are set up 
in Editor.

Check only if the User must have the same 
rights as the system administrator.
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Starting the Server

 

To run the Server, select 

 

Start > Programs > Smart Alec

 

. Then 
open the 

 

Smart Alec Launch Utility

 

. A default list of applications 
will be launched.

 

Using the Smart Alec Launch Configuration Utility

 

To add or delete from the default list of applications, open the 

 

Smart Alec Launch ConÞguration Utility

 

:

This is a list of Smart 
Alec applications that will 
not be launched.

An application can be set to open Minimized or 
Normal (as an open window).

This is a list of Smart Alec applications that will be 
launched when Smart Alec Launch Utility is run.

See “Using the “Selected 
Applications Command 
Line”” on page 14.

Applications can be moved from one side to the other by dragging and 
dropping. (To remove an application, select it and then press the Delete key.)
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Launching “external” applications

 

In addition to Smart Alec applications, any executable Þle 
can be added to the 

 

Launched Applications

 

 list. For example, if you 
have a DDE connection to a Microsoft Excel Þle you can use 

 

Windows Explorer

 

 to add the Excel executable to the 

 

Launched 
Applications

 

 list (as shown below):

To add Excel to the list of 
Launched Applications, drag 
the Excel icon from Windows 
Explorer to the Launched 
Applications window.
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Using the “Selected Applications Command Line”

 

The 

 

Selected Applications Command Line

 

 gives you the ability 
to open a particular document along with its application. For 
example, if you wanted to open an Excel spreadsheet named 
UTILITY.XLS, do the following:

1. Select the application (in this case Excel) from the 

 

Launched Applications

 

 list.

2. Add the applicationÕs document (in this case UTILITY) 
full Þle path after the applicationÕs executable Þle path:

This is the full file path 
of the application Excel.

This is the full file path of Excel.

This is the full file path of the Excel spreadsheet. In this case, utility is in 
the same directory as the executable, so the file path is simple. 
Remember to leave a space between the executable and the document.
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User (Client) installation

 

1. Close all applications on your computer.
2. Insert the Smart Alec CD-ROM in your computer. The 

installation program will autostart, and this screen 
should appear:
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3. If there is a version of Smart Alec already on your 
computer, the following prompt will appear:
¥ Select 

 

Yes

 

 if you want to remove an older version. 

 

After un-installation is Þnished, you will have to 
re-start the install program.

 

¥ Select 

 

No

 

 if you need to keep the previous version of 
software. Normally, there should be no need to keep 
an older software version.

4. The installer will display prompts in which you must 
accept the End-User Agreement.

5. You will be prompted whether or not to install the Smart 
Alec Server, Client, or both software:

Selecting Yes deletes all setup 
information — Users, Locations, etc. 
Make sure all this information is 
recorded before continuing.

Since you’re just installing 
the Client, select this option.



User (Client) installation 

Installing Smart Alec software 17

6. Next, enter the following information:

7. The installation program will search for the Smart Alec 
Server (ALEC.EXE). If the Server is not found, locate the 
Server by using Browse:

If the installation program does not find the Server (ALEC.EXE), 
then you must locate and “map” the Server for the Client.
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8. Next, select a directory for the Client Þles:

9. To check if the installation was successful, look at the 
Start > Programs list for Smart Alec.

Un-installation

To un-install Smart Alec, just re-run the installation program 
from the CD-ROM.

When the following prompt appears, select Yes:

To install the Client in a different 
directory or computer, use Browse.

Selecting Yes deletes all setup information 
— Users, Locations, etc. If you want to 
preserve this information, make sure it 
is recorded before continuing.
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Basic messaging

Because the Smart Alec software allows you an inÞnite 
number of ways to create a message for a device like a sign or 
pager, there is no way to show every possible example.

However, in the following pages, examples of basic and 
advanced messaging will be presented.

First, the basics . . .
Messages can come from a variety of different sources:

Example 1 — Your first message

Open the Editor
1. To create your Þrst message, open the Editor. At the 

prompt, type your Username and your Password:

Email

ASCII

User

ALPHA SA signs

DDE, sockets

Pagers

Serial

Smart Alec ApplicationsData source Data output

This is an option that can be purchased separately.

Email Gateway

Editor

ASCII File Input Interface

ALPHA SA - Output Interface

Variable Manager

Serial data input interface

Pager - Output Interface1

1

1

EmailEmail - Output Interface1

This is 
covered in
this chapter, 
“Basic 
messaging”.

These are 
covered in 
the next 
chapter, 
“Advanced 
messaging”.

NOTE
The default Username is “alec”.
There is no default Password.
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Create a message
2. Select File > New Message and type ÒYour Þrst messageÓ 

in the message window:

Select where a message will be sent
3. To choose a place (or places) for the message to go, select 

Submit > Setup Options. This window will appear:

NOTE
Instead of selecting File > New 
Message to create a new 
message, you can use this icon:

NOTE: The Smart Alec Submission Options window will 
open automatically if no Destination Locations 
have been selected. Otherwise, select Submit 
> Setup Options to open this window.
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4. Select a Location from the list of Available Locations Ñ 
Production (Group) in this case Ñ and then click on the 
<-----> button:

Select one or more Locations where your 
message will be sent. (The Available 
Locations for each User are set using the 
Administrator application.)

Then click on this button to move a 
Location to the Destination Locations 
list.

Your message will be sent to all the 
Locations that appear in this list.

When (Group) appears at the end of a 
name, it means the name represents 
multiple Locations. In this example, 
Production (Group) consists of the 
Engineering, Manufacturing, and 
Shipping Locations.

The Priority level affects when a message is 
displayed. Exclusive 8 is the highest level.

Run Schedules = message will be 
displayed when a preset time is 
reached.
Run Variables = message will be 
displayed when a Variable reaches 
a certain value or “trigger”.
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Select when and how long a message will be displayed
5. In the Smart Alec Submission Options windows, select 

Scheduled Options and set when a message will be 
displayed. Then select OK:

An Immediate Message will be sent 
as soon as you click on OK.

An Immediate Message can only be 
scheduled to appear for a certain 
length of time (or duration)

If this box is not checked, then more 
scheduling choices are available.

If checked, the time used in scheduling will 
be the time on the computer that is running 
the Smart Alec Server.
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Send the message
6. After clicking on OK, select Submit > Submit Message to 

send the message:

Watch the message
7. After a message is submitted, it can be tracked by 

watching its Status in the Message Server application:

NOTE: The Status of a message Ñ Pending, Running, or 
Complete Ñ indicates the status of a message 
within the Smart Alec Server. Because Smart Alec 
software does no handshaking with output 
devices, the Status condition does not reßect if a 
message was actually received and displayed by 
an output device.

NOTE
Instead of selecting Submit 
Message to send a message, you 
can use this icon: The Editor’s status 

line lets you know 
that the message 
has been sent.

Message 
file (MSA) 
version 
number.

Message 
filename 

path.

Message 
priority:

0 = lowest,
9 = highest.
(0 = Normal,

1 = High,
2-9 = Exclusive)Message 

destination

See 
NOTE 
above.

Message 
creator

Message start and 
stop indicators:
Start/End set by
Run Schedule.

Trigger On/Off set by 
Run Variables. 

(See “Select when and 
how long a message 
will be displayed” on 

page 22.)
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Example 2 — Using Modes to change how a message looks

ÒModesÓ are special effects that change the way a message 
appears on a sign. For example, the Rotate Mode moves a 
message from right to left across a sign. In this example weÕll 
create a message that displays employee birthdays.

NOTE: Some Modes are not available on all signs. See 
ÒAppendix H: What Modes are available on signsÓ on 
page 114.

1. To create the Example 1 message above, open the Editor. 
Select File > New Message to open a new message 
window. Then select Modes > Hold:

In this example, the Hold and Rotate Modes are used to display employee birthdays. 
This set up can be used for a variety of uses such as announcements and anniversaries.

Using the Hold Mode, the 
top line remains fixed 
while the names go by.

Using the Rotate Mode, 
the names move from right 
to left on the bottom line.
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2. When the following window appears, select Top:

3. The icon for Hold will appear in the message window:

4. Type ÒBirthdaysÓ. Select Modes > Rotate > Standard and 
the Bottom line position. Then type ÒTom White, Patty 
Smith, Bob EvansÓ:

Line Position is where a message appears on a 
sign. See “Appendix L: Understanding line 
positions (Top, Middle, Bottom, Fill)” on page 118.

NOTE
Place the cursor over an icon 
and press the right mouse 
button to see a short 
description of the icon:

Right 
mouse 
button

Top line position

Bottom line position

Middle line position

Fill line position

A dot on 
the Hold 
icon 
shows the 
message 
line 
position.
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5. To get an idea of how this message will look on a sign, 
select File > Emulate All. When the Smart Alec Emulator 
window appears, click on the stop button. Then extend 
the right side of the window:

6. Next, instead of simulating a 3-line sign (like the 7120C), 
weÕll emulate a 2-line sign. To do this, select Options > 
Sign Model. Then choose 316-120T/4120C and select OK:

Extend 
this 
side of 
the 
window.

Stop button Start button

Current Mode Message speed
(S5 = fastest, S1 = slowest)

ALPHA SA sign model
(a 7120C is a 3-line, 
tri-color sign)

This is the 2-line sign we’ll emulate.
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7. Now run the message on the Emulator:

NOTE
The Smart Alec Emulator does 
not show exactly how a message 
will appear on a sign — that is, 
it’s not WYSIWYG (What You 
See Is What You Get).

However, the emulator should be 
used to check how fonts and 
colors will appear on a sign — 
and also how much text will 
appear on a line.
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Example 3 — Using Characters to change how a message looks

ÒCharactersÓ are options that change the appearance of text 
in a message. For example, normal-sized text (called Seven Row 
Normal) is seven LED rows high. However, some signs allow you 
to create text that is 15 or 16 rows high using the 15/16 Row 
Normal option.

In this example, weÕll create a message that displays airline 
fares.

NOTE: Some Characters are not available on all signs. For a list 
of what is available, see ÒAppendix I: What Characters 
& Colors are available on signsÓ on page 115.

1. Open the Editor. Select File > New Message to open a new 
message window. Then select Modes > Roll > In:

In this example, the Roll mode, 15/16 Row Normal text, and the 
New Line option are used to display airline prices for several cities.

A single message will be 
used to create large text on 
2-line signs and normal text 
on 1-line signs.
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2. Select Top when this window appears:

3. Because we want large text, select Characters > 15/16 Row 
Normal. Then type ÒLas Vegas $85, Chicago $199, New 
York $235Ó:

OOPS!
By selecting Top, we’ve made an 
error that will show up later.

However, we’ll keep going to 
demonstrate a common mistake 
and how to correct it.

15/16 Row Normal icon
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4. LetÕs see how the message looks so far. First, letÕs see how 
it looks on a 1-line sign. Run the Smart Alec Emulator. 
Select Options > Sign Model and change the sign being 
emulated to 215C. Start the emulator and this should 
appear:

5. Stop the emulator and change the sign to a 4120C (a 2-
line sign). Re-start the emulator. You should see this:

Why doesnÕt the large text appear on the 2-line sign?

Because in a previous step, we selected the Top instead of 
the Middle line position:

6. To make sure the large 15/16 Row Normal characters 
appear correctly on a 2-line sign, start by deleting the Roll 
icon from the message:

Since a 1-line sign like the 215C can’t display 15/16 
Row Normal, the sign displays the smaller Seven Row 
Normal instead. This is what we want.

To make the large 15/16 Row Normal 
text appear correctly, the line position 
must be changed from Top to Middle.

To delete the Roll icon, place 
the cursor after the icon and 
press Backspace.
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7. Next, without moving the cursor in the message, select 
Modes > Roll > In as you did before. Then, when the 
following window appears, select the Middle line 
position:

8. Now display the message on a 2-line sign in the Smart 
Alec Emulator:

Your message text should now look like this:

9. Select File > Save and save your message as TEST1:

The large 15/16 Row Normal 
text now appears correctly.

Notice that the dot on the Roll icon 
indicates the Middle line position.
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10. WeÕd like to display a city name and dollar amount at the 
same time on a sign. In order to do this, add Option > 
New Line after each city-dollar pair. The message should 
look like this:

11. Run the Smart Alec Emulator to see the effect of adding 
New Lines:

NOTE
Don’t use carriage returns to 
break up a line of text — use 
New Line.

These are the 
New Line icons.

The New Line Option 
formats text correctly.
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Example 4 — Using graphics in a message

The Animation and Graphic Options allow you to include 
small bitmapped graphics in messages:

The Animation Option is a series of moving images Ñ like 
Cherry Bomb and Fireworks Ñ that have already been created for 
you. For example, Running Animal will display a horse galloping 
across a sign.

With the Graphic Option, you can create your own bitmapped 
image which can then be placed in a message. 

NOTE: Before creating a bitmapped image, make sure you 
understand how images are displayed on a sign. (See 
ÒAppendix M: Understanding how text and graphics 
are displayed on signsÓ on page 119.)

NOTE: Because bitmapped image editing software is not 
included with Smart Alec software, youÕll need a 
program to create, edit, and save images. In the 
following example, the Paint Shop Pro program is 
used.

The Animation and Graphic 
Options are used to display 
moving and still images on a sign.

These are the only 
moving images that can 
be displayed on signs.



Example 4 — Using graphics in a message 

34 Basic messaging

In the following example weÕll make a left and a right 
ÒarrowÓ and then use the Graphic Option to display both arrows 
on a sign:

1. To make the two graphic arrows, the program Paint Shop 
Pro will be used. However, any bitmapped graphics 
editor can be used as long as the images can be saved as a 
BMP Þle, and the editor should have a ÒzoomÓ function 
to make images easily viewable.
Open Paint Shop Pro:

The two arrows we’ll make 
are 7 rows (or pixels) high. 
Using this height permits the 
arrows to be used on both 1-
line and 2-line signs.

2-line sign

1-line sign
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2. Next, select File > New. When the New Image window 
appears, make the width and height of the new graphic 
16 x 7:

NOTE: Width and Height deÞne the size of the graphic 
in pixels Ñ in this case, 16 pixels wide x 7 pixels 
tall. These numbers also correspond to a signÕs 
columns and rows Ñ the 16 x 7 graphic will 
occupy a space 16 columns wide x 7 rows tall.

3. After selecting OK, a very small window should appear. 
Increase the size of this window using the editing 
softwareÕs zoom feature:

We’re using 7 because this is the 
height of a single line on a sign.

Because a maximum of 
only 8 colors can be 
used on a sign, select 8 
or 16 colors instead of 
256 colors, if possible.

Use the zoom feature to increase 
the size of the small window until 
16:1 appears on the window.
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4. Select a color for your graphic:

5. Draw the right arrow and save it as a BMP graphic 
named RARROW.BMP:

Be careful what color you use. Not 
all colors can be displayed on all 
signs. (See “Appendix M: 
Understanding how text and 
graphics are displayed on signs” 
on page 119.)
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6. Create the other arrow and save it as LARROW.BMP:

7. Next, open the Smart Alec Editor. Select File > New: and 
then Options > Graphic. When the Select Graphic window 
appears, select the RARROW.BMP Þle you just created:

8. Next, type ÒNewsÓ after the Graphic icon. Then use 
Graphic again to add the LARROW.BMP Þle after the 
word ÒNewsÓ:

9. Finally, run the message emulator to preview the 
message:

Right arrow graphic (RARROW.BMP)

Left arrow graphic (LARROW.BMP)

This is how the message looks 
on the 4120C, a 2-line sign.

This is how the message looks 
on a 215C, a 1-line sign.
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Advanced messaging

Using variable data in messages

The Variable Manager is responsible for bringing variable 
(changeable) data from outside the Smart Alec system into Smart 
Alec. An example might be to display the temperature of a liquid 
on the production ßoor in a message. 

Variables can be used to:
¥ change the content of a message, and
¥ trigger a new message

Example 1 — Changing the content of a message
In this example, we will create a message which contains the 

time and send the message to a sign. The message on the sign will 
always show the correct time.

You need to run the following Smart Alec components and 
log in as user ÒAlecÓ to use this example:

¥ Message Server
¥ Editor
¥ Variable Manager
¥ Clock Variable Demo (Clocksrc)
¥ ALPHA SA Output Interface
¥ Device Driver - Wired

NOTE
We could show the time easily 
with an option in the Editor, 
but this is a simple example 
with tools you have now.
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1. Open Variable Manager.

2. In the Editor, select File > New Message.

3. Select Mode > Hold. Then select Fill and OK. This way, the 
message will remain in one place on the sign.

If the items in this window 
don’t appear, select File > 
Open. Then open the file 
varmng1.vmg. This file is 
located in the same 
directory as the Variable 
Manager.



Using variable data in messages 

Advanced messaging 41

4. Select Options > Speed > Speed5. This way, the message 
will be shown quickly and the Variables will be updated 
frequently.

5. Type ÒTime: Ó in the message (with a space at the end.)

6. Select Options > Variables, highlight Hour, and then OK.
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7. Type Ò:Ó in the message (with no spaces before or after.)

8. Repeat Steps 6 and 7 for Minute. Then repeat Step 6 for 
Second. Your message should now look like this:

9. Select Submit > Submit Message, highlight the name of the 
destination location. (For this example, the destination 
location must be for a sign, not a pager or email.) Then 
click the double-arrow button to set the destination.
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10. Select the Scheduled Options tab and then OK to let the 
message run for the default two minutes.

You should now see the time being updated on the ALPHA 
sign, like this:

Note that the display of 
the seconds may appear 
to skip from time to 
time. This is due, not to 
the counter in the sign, 
but rather to how quickly 
Smart Alec can update 
the sign.
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Example 2 — Sending a new message based on changing data
Smart Alec can be used to start a message when data outside 

of Smart Alec changes. In this example, we will create a message 
that alerts us at 30 seconds after each minute.

You will need to run the following Smart Alec components 
and log in as user ÒAlecÓ to use this example:

¥ Message Server
¥ Editor
¥ Variable Manager
¥ Clock Source
¥ ALPHA SA Output Interface
¥ Device Driver - Wired

Here are the steps to take to make this happen:
1. In the Variable Manager, select File > Open and open the 

Þle VARMNG1.VMG, if itÕs not already open. This Þle is 
located in the same directory as the Variable Manager.

2. In the Editor, select File > New Message.
3. Select Mode > Hold. Then select Fill and OK.
4. Type ÒSeconds have exceeded 30!Ó in the message.

5. Select Submit > Submit Message.

NOTE
Example 2 assumes you are 
familiar with the steps in 
Example 1.
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6. Highlight the name of the destination location, select the 
double-arrow button and then Run Variables:

7. Select the Variable Options tab.
8. Click anywhere in the Start box and the word ÒNoneÓ 

will disappear.
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9. In this step we will create a statement to determine when 
to start running the message. Double-click on Second in 
the Available Variables list. Next, click once on the buttons 
for >, 3, and 0, in that order.

10. Click anywhere in the Stop box and the word ÒNoneÓ 
will disappear.

11. In this step we will create a statement to determine when 
to stop running the message. Double-click on Second in 
the Available Variables list. Next, click on the buttons for 
<=, 3, and 0.

While you can 
type this in 
directly, using 
the mouse is 
more reliable.

NOTE
For either the Start or Stop condition, if 
you enter a negative number or an 
alphabetic character, (like when 
“Temperature <= -50” or when “Status 
= On”) then when you select OK, Editor 
shows an error for an “undefined 
Variable” and asks if it should be 
accepted. As long as the condition is 
correct, choose Yes and ignore the 
warning.
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12. Click OK. to set these run conditions and send the 
message. Now each time the seconds in the Clock Source 
are greater than 30, the message ÒSeconds have exceeded 
30Ó! should appear on the display, as shown below. Each 
time the seconds return to zero, the message will no 
longer appear on the sign.
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Example 3 — Stopping a message
1. The message in ÒExample 2 Ñ Sending a new message 

based on changing dataÓ will continue as long as Smart 
Alec remains running. To stop the message, select Submit 
> Replace Message in the Editor.

2. Highlight the name of the message you want to turn off 
(e.g., Òalec2Ó). The contents of each message and its run 
conditions are shown in case youÕre not sure which to 
choose.

3. Select the Delete button, and then select OK.
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Example 4 — Changing the appearance of data in a message
In addition to simply using data from outside of Smart Alec, 

you can determine how the data should look in the message 
based on the value of the data. In this example, weÕll set two 
conditions for the Second data. This way, whenever Seconds are 
shown in a message (like Example 1 with Hours/Minutes/
Seconds) the Seconds will stand out from the rest of the message.

1. In the Variable Manager, highlight the Item for which you 
want to create a proÞle. For this example, choose 
Òstring6Ó for Second.

2. Select Edit > ProÞle as in the picture above.
3. For the Level, enter the value at which the appearance 

should change. WeÕll specify Greater or Equal to 0. This 
means that the appearance will change when Seconds is 
zero, that is, every minute. 

The profile can change the 
color or flashing state of the 
data in the message 
(provided the sign supports 
these) without changing the 
looks of the surrounding text. 
If a profile is not defined for 
the data, the data will be 
displayed with the same 
looks as the rest of the 
message text.
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4. Select the color and ßashing state for this Level. Select 
Green and Flashing Off. At the start of each minute, we 
want the display of Seconds in the message to be shown 
in green and to not ßash. 

5. Select the Set button. (DonÕt click OK yet.) This step 
creates a ÒstatementÓ shown on the left side. This 
statement basically says, ÒWhen the value of Seconds is 
greater or equal to 0, show it in green and be sure itÕs not 
ßashing.Ó

6. Now weÕll create another statement. Set the Level to 
Greater or Equal to 30. And select Red and Flashing On. 
Select the Set button again. This means that at 30 seconds 
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after each minute, the Seconds will be shown in red and 
will ßash. 

7. Click OK. Now, when you run the message we created in 
ÒExample 1 Ñ Changing the content of a messageÓ on 
page 39, the look of the seconds will change every half-
minute.
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Example 5 — Listing Variable Profile statements in a new order
Say you had made another statement for setting the looks of 

Second when it gets to 20. Each time you set another statement, 
itÕs put at the end of the list, like this:

But when you look at the list, the statements are not in order 
of low to high, based on Level. You want to move the statement 
for 20 after the one for zero and before the one for 30. 

HereÕs what to do:
1. Right-click on Level 20 in the list. A short pop-up menu 

will appear. Click on Move.
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2. Another window will appear. Click on After and leave 
zero highlighted. Then click OK.

3. The result is an orderly sequenced list. NOTE
Changing the sequence of the list 
statements does not change 
their effect. It just gives an 
ordered list for ease of 
understandability.
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Example 6 — Displaying data from an Excel spreadsheet
You can include information from a spreadsheet in a 

message.
You will need to run the following Smart Alec components 

and log in as user ÒAlecÓ to use this example:
¥ Message Server
¥ Editor
¥ Variable Manager
¥ Microsoft Excel
¥ Alpha SA Protocol Converter
¥ Device Driver - Wired
¥ Administrator (wherever authorization is done)

In the spreadsheet:
1. Set up the spreadsheet as needed. For this example, just 

open a new Excel spreadsheet. In cell A1, type Ò5Ó and 
press the Return key. Save the spreadsheet as 
ÒBook1.xlsÓ.

 In Variable Manager:

2. Choose Connect from the DDE menu.

NOTE
Always be sure to have the 
spreadsheet open when including 
its data in a message and running 
that message.
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3. Specify the Service for this spreadsheet (ÒExcelÓ, for 
Microsoft Excel) and the Topic (e.g., Ò[Book1.xls]Sheet1Ó). 
Click OK

4. Specify the Item you need (e.g., the name of the 
spreadsheet cell, in this example Òr1c1Ó). You can provide 
an Alias (meaningful name) here also. Specifying the 
Service, Topic, and Item makes the cell data available to 
Smart Alec. Click OK.

Here, the Topic identifies the 
specific spreadsheet you want 
and the specific sheet within that 
spreadsheet. Always identify both 
the spreadsheet and the sheet.

The Service identifies the 
software application where the 
data is coming from.

NOTE
Cell A1 in an Excel spreadsheet is referred 
to as cell “r1c1” (or “R1C1”). This refers to 
“row 1, column 1.”

The data is identified by its Alias 
in Smart Alec. (The Alias defaults 
to the Item name if you don’t put 
one in.) Leaving Register Now checked makes the 

data available in the Administrator so the 
data can be assigned for access by users. 
Once users have access, they can use the 
data with messages. If registered, the 
data counts toward the number of 
licensed variables. If not registered, the 
data is only available for purposes of 
testing a DDE connection.

You can add 
more than 
one Item by 
clicking Add.

The Conversation is 
a combination of 
Service and Topic.

Size sets the maximum 
number of characters to 
be allowed for this item. 
If the size is not large 
enough, the data may be 
ignored in the message.

Padding can fill in missing 
spaces automatically if 
the number of characters 
is less than the maximum 
size. This is helpful when 
there are columns of data 
in a message.
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5. YouÕll see the Item Òr1c1Ó listed.

 In the Administrator:

6. You must be authorized to use the variable data. 
Generally, this will be done by your Smart Alec 
administrator.
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 In Editor:

7. In Editor, open a new message. Type ÒCell A1 data: Ó, 
with a space at the end. Then choose Options > Variables.

8. Highlight r1c1_cell in the list, and click OK.

9. Submit the message. It should look like the one shown 
here.

10. Change the spreadsheet data, and the message changes.

If r1c1_cell does not 
show in the list, you 
probably are not yet 
authorized to use it. 
See step 6 above.
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Example 7 — Using sockets to get data
There are two ways to get data into Smart Alec. One uses 

DDE, as in ÒExample 6 Ñ Displaying data from an Excel 
spreadsheetÓ on page 54. The other uses socket communications, 
most commonly with TCP/IP. Socket usage allows Variables to 
be registered, sent, and updated from other applications that do 
not use DDE and/or other computers. Socket communications 
can be used by programmers to integrate software, such as 
warehouse management systems, with Smart Alec.

This example shows how to use data from applications using 
sockets.

In Variable Manager
1. Select Socket > Open.

2. The Open Socket window displays the IP address it found 
for this computer and the default Port number (1069). 
The Port number in Variable Manager must agree with the 
number identiÞed in the sending application. You can 
change the Port numbers, but they must agree. Click OK.

In the sending application

3. Supply the IP address and the default Port number 
(shown in step 2) for the Variable Manager computer and 
open a conversation to the Variable Manager.

NOTE: Sending application processing is beyond the scope of 
this manual. A document (System Integration Input 
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Interface DeveloperÕs Reference PN 9709-2029) is 
available for application developersÕ reference.

4. Start and stop submitting data as needed in the sending 
application.

In Variable Manager 

5. Variable Manager can send back status messages.
6. Error messages are logged in Variable Manager's Error 

Log. Select View > Error Log.

7. When you no longer need the data from the sending 
application, select Socket > Close.
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Using template messages

A template is a blueprint or a skeleton of the text, formatting, 
and submission options or properties of a message. 

There are two ways to use a template message:
¥ A personal template message which can be used from the 

Editor so that you start with one basic message each time 
rather than recreating a message over and over

¥ A template message which can be merged with a Þle of 
text (created outside of Smart Alec) to send a complete 
message

Example 1 — Creating a template message to run from Editor
This example creates a message that contains both text that 

does not change and text that will change periodically. The 
advantage is that you can run the message and supply just the 
text that changes without worrying about the text that does not 
change. You donÕt need to create similar messages over and over.

You need to run the following Smart Alec component and log 
in as user ÒAlecÓ to use this example:

¥ Editor

1. In the Editor, choose File > Create New Template.

2. Type ÒHappy birthday to Ó, with a space at the end.
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3. From the Options menu, choose SA Text Marker.

4. Leave the Field Number as 1. Type ÒBirthday personÓ in 
for the Label.

5. The message now looks like this:

The value of the Field Number here 
coordinates with the sequence of the 
fields in a text file which can supply the 
values. For further explanation, see 
Template Examples 3, 4, and 5, and 
“Appendix P: Formats of ASCII-delimited 
files” on page 125.
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6. Hint: To see what an icon in the message stands for, place 
the cursor over (or just to the left of) the icon and then 
press the right mouse button. The explanation shows in 
the status bar.

NOTE: The template message must have at least one SA Text 
Marker.

7. Choose Submit > Setup Options and select a Destination 
Location. For this example and the next, choose a sign 
location, not pager or email. 

A Text Marker acts 
like a placeholder 
in a message.
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8. Choose the Scheduled Options tab and set the Duration for 
the message to 30 minutes. Click OK.

9. Choose File > Save. Editor displays the prompt shown 
here. Click No for now. Give it a Þlename of ÒBirthdayÓ 
and click OK.

10. Now the template message is ready to use. SeeÒExample 
2 Ñ Running the template message in EditorÓ.

Refer to “Example 8 — 
Setting who can use the 
message” on page 79 
for more explanation of 
this prompt.
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Example 2 — Running the template message in Editor
This example shows a simple way to run the message created 

in Example 1.
You need to run the following Smart Alec components and 

log in as user ÒAlecÓ to use this example:
¥ Editor
¥ Message Server
¥ Device Driver - Wired
¥ Alpha SA Protocol Converter

1. In Editor, choose File > New Template Msg.

2. Choose birthday.mst.
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3. The message opens up and looks very much like any 
other message, except that the cursor is placed with the 
Text Marker, which is highlighted to be replaced.

4. Without moving the cursor, type ÒGeorgeÓ. Notice how 
the Text Marker disappears when you start to type.

5. Choose Submit > Submit Message. The message on the 
sign will look something like this:
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Example 3 — Creating a template message to merge with a text 
file 

This example creates a template message to list todayÕs 
meeting schedule. This message will have three Text Markers: 
time, room number, and group. This example and template 
message are to be used in conjunction with ÒExample 4 Ñ 
Creating a text Þle to merge with a messageÓ on page 68 and 
ÒExample 5 Ñ Running the template message: merge text and 
templateÓ on page 69. 

You need to run the following Smart Alec component and log 
in as user ÒAlecÓ to use this example:

¥ Editor

1. Create a New Template.

2. Type ÒTodayÕs meeting: Ó, with a space at the end.
3. Add a Text Marker and label ÒMeeting timeÓ.
4. Type Ò Room Ó, with a space at the beginning and end.
5. Add a Text Marker and label ÒRoom numberÓ.
6. Type Ò: Ó, with a space at the end.
7. Add a Text Marker and label ÒGroupÓ.
8. Set the destination and the time to run it.
9. Choose File > Save.

10. When Editor asks if you want other users or applications 
to have access, choose Yes.
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11. Save the template as ÒMeeting1Ó. The extension of Ò.mstÓ 
will be put on for you. It is saved in the Server\Templates 
directory.

12. The template message should now look like this:

13. The template message is now available for the Smart 
Alec administrator to grant access to individual users.
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Example 4 — Creating a text file to merge with a message
This example creates a text Þle to be used in conjunction with 

ÒExample 3 Ñ Creating a template message to merge with a text 
ÞleÓ on page 66 and ÒExample 5 Ñ Running the template 
message: merge text and templateÓ on page 69. This text Þle 
supplies variable data for the message.

You need to run the following to use this example:
¥ Notepad (Windows>Start>Programs>Accessories> 

Notepad)

NOTE: The format of the text Þle in this example conforms to 
the ÒBasic DAQ FormatÓ as described in ÒAppendix P: 
Formats of ASCII-delimited ÞlesÓ on page 125.

WeÕll create a text Þle to Þll in the blanks when the message is 
run:

1. In Notepad, type ÒMeeting1,alecÓ with no spaces before or 
after the commas. Press the Return key.

2. Type Ò10:00,200,Sales and MarketingÓ with no spaces 
before or after the commas.

3. The Notepad Þle should look like this:

4. Save the Þle as ÒMeeting1Ó. The extension of Ò.txtÓ will 
be put on for you. You can save it anywhere you wish.
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Example 5 — Running the template message: merge text and 
template

Smart Alec allows you to merge a text Þle with a predeÞned 
template. The templates are created in the Editor with blank Þelds 
deÞned as SA Text Markers and the ASCII-delimited Þle provides 
the information for the SA Text Markers in the template.

You need to run the following Smart Alec components and 
log in as user ÒAlecÓ to use this example:

¥ ASCII File Input Interface
¥ Message Server
¥ Device Driver - Wired
¥ Alpha SA Protocol Converter

It works this way:
1. You must have created a template with SA Text Markers. 

(See ÒExample 3 Ñ Creating a template message to 
merge with a text ÞleÓ on page 66.)

2. You must have created a text Þle for the template SA Text 
Markers in an ASCII- delimited Þle format. (See 
ÒExample 4 Ñ Creating a text Þle to merge with a 
messageÓ on page 68.)

3. Bring ASCII File Input Interface to the front. Click the 
About button. Note the Inbox shown. You may want to 
write down the directory name. Click OK, then minimize 
ASCII File Input Interface.

NOTE
The ASCII File Input Interface 
application must be running to 
use ASCII-delimited files.
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4. In Windows Explorer, make a copy of the Notepad Þle in 
the same directory. Rename it to ÒMeeting1.daqÓ. 
Explorer will warn you about changing the Þlename 
extension. Choose Yes anyway. 

5. In Windows Explorer, move ÒMeeting1.daqÓ to the inbox 
directory of the ASCII File Input Interface which you noted 
in Step 3, shown below as C:\Alec\Server\12.

6. The ASCII File Input Interface automatically takes the Þle 
out of this Inbox and merges the text for the SA Text 
Markers with the template. The message is set to run as 
scheduled, immediately in this example because that 
option was chosen in Editor.

7. The ASCII File Input Interface merges the template and the 
text into a Þle, converts the Þle into an .MSA Þle format, 
and sends the message to the destination sign.
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8. The message on the sign will look something like this:
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Example 6 — Setting the Location for a template message
LetÕs say you want to send a template message to different 

locations depending on other circumstances to be determined 
only when the message is sent. In this case, you donÕt want to set 
a location when you create the template message. You want to set 
the location when you send the message. This example shows 
how to do that.

You need to run the following Smart Alec components and 
log in as user ÒAlecÓ to use this example:

¥ Editor
¥ Message Server
¥ Device Driver - Wired
¥ ASCII File Input Interface
¥ Alpha SA Protocol Converter
¥ Notepad (Windows>Start>Programs>Accessories> 

Notepad)

1. In Editor, choose File > Create New Template.

2. Type ÒMeeting in Room Ó, with a space at the end.
3. Add a Text Marker and label ÒRoom numberÓ.
4. Choose Submit > Submit Options. At the top of the list of 

Available Locations is Ò@SubmitÓ. Move this to the 
Destination Locations list. Ò@SubmitÓ must be the only 
item in the Destination Locations list.

Using @ Submit means that 
the Location will have to be 
set either when the message 
is submitted from the Editor 
or in a text file with the ASCII 
File Input Interface.
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5. Click on the Scheduled Options tab. Leave Immediate Mode 
checked and the duration as 2 minutes. Click OK.

6. Choose File > Save. Give other users access.
7. Save the Þle as ÒMeeting2Ó.
8. Open a new Þle in Notepad. On the Þrst line, type 

ÒMeeting2,alecÓ for the Þlename and user. On the next 
line, Type the destination name that you wish, followed 
by Þve commas. On the last line, type Ò200Ó. The Þle 
should now look like the picture below.

NOTE: The format of the text Þle in this example conforms to 
the ÒExtended DAQ FormatÓ as described in 
ÒAppendix P: Formats of ASCII-delimited ÞlesÓ on 
page 125.

9. Now follow ÒExample 5 Ñ Running the template 
message: merge text and templateÓ on page 69 to send 
the message. It should look like this:

The commas act like 
placeholders. You don’t need 
to fill in all the fields, but you 
must have all five commas. 
See “Appendix P: Formats of 
ASCII-delimited files” on 
page 125 for details.
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Example 7 — Setting how and when the message is to start running
You can set the message to start running based on time or 

based on the value of a variable. The ßowchart below shows all 
the options. 

A message set to run based on time has Þve scheduling 
parameters which must be detailed: start date, start time, end 
date, end time, and duration. Any or all of these can be set when 
the template message is created. They also can be set when the 
message is run, by using the @Submit option.

This example shows how to run a message where some 
parameters will be scheduled and some will be set at the time the 
message is submitted.

Is the
message to run

based on timing?

Is the
message to start

immediately?

No

Yes

Start

Check Run Schedules

Check
Immediate Mode

Is the
message of fixed

duration?
Set the duration

Set @Submit

Is the
message to run on a

fixed schedule?

Check Run Variables

Are any
parameters fixed?

Set the schedule
(all parameters)

Set @Submit

Leave all parameters
as @Submit

Set individual
parameters

End

Yes

Yes

Yes

No

No

No

Yes

No

See “Example 2 — 
Sending a new 

message based on 
changing data” on 

page 44.
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You need to run the following Smart Alec components and 
log in as user ÒAlecÓ to use this example:

¥ Editor
¥ Message Server
¥ Device Driver - Wired
¥ Alpha SA Protocol Converter
¥ ASCII File Input Interface

Assume you have two main work areas: Production and 
OfÞce. Production works from 6:00 AM to 2:30 PM, while the 
OfÞce works from 8:00 AM to 5:00 PM. For each group, you have 
created a template message like ÒMeeting1Ó in ÒExample 3 Ñ 
Creating a template message to merge with a text ÞleÓ on 
page 66. Each group has meetings from time to time, but not 
every day. You want to set the message to run at the times when 
people are at work and only when there are meetings pertinent to 
each group. WeÕll go through setting up the message for 
Production.

1. In Editor, open the ÒMeeting1Ó template message. Select 
Submit > Setup Options. Since this will be based on time 
rather than Variables, select Run Schedules for Message 
Mode.
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2. Click on the Scheduled Options tab. We want to set the 
start time of the message based on ProductionÕs work 
hours, so click on the Immediate Mode checkbox so that it 
is not checked. 

3. Click Set @ Submit. This sets all the parameters to be 
determined at the time the message is sent. WeÕll adjust 
this in the next step. 



Using template messages 

Advanced messaging 77

4. In the Start Time box, click on the up and down arrows to 
set the time to 6:00 AM. Leave the Stop Time, Start Date, 
and Stop Date boxes set to @Submit. Click OK.

5. Save and close the template message.
6. Choose File > New Template Msg. Click on ÒMeeting1Ó 

and then Select.

7. For the Þrst prompt, type Ò8:00Ó. Tab to the next prompt 
and type Ò101Ó. Tab to the last prompt and type ÒHealth 
planÓ.

8. Choose Submit > Submit Message.

These set 
the hour.

These set 
the minutes.



Using template messages 

78 Advanced messaging

9. Now you need to set those parameters that were not set 
earlier, namely the Stop Time, Start Date, and Stop Date. 
Again using the up and down arrows, set the Stop Time to 
one hour after the meeting time, in this case 9:00. Click 
once on either of the up arrows for the Start Date and Stop 
Date to set them to todayÕs date. 

10. Select OK. The message is submitted and will run from 
6:00 AM to 9:00 AM today. 
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Example 8 — Setting who can use the message
1. When you save a template message, the prompt shown 

below is displayed.

¥ Choose No if the template will only be used by you, 
or if you want to use the template message as a 
message whose Þelds will be entered in the Editor.

¥ Choose Yes if you want other users to be able to use 
the template, or if you want the ability to merge text 
for SA Text Markers from other applications.

2. In the Administrator, if you chose Yes in step 1, any other 
Users must be authorized for the template.

3. When a User selects File > New Template Message, a list of 
authorized templates appears to choose from.

4. Highlight one and click Select to use it for a message.
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Example 9 — Using repeating records
You need to run the following Smart Alec components and 

log in as user ÒAlecÓ to use this example:
¥ Editor
¥ Message Server
¥ Device Driver - Wired
¥ Alpha SA Protocol Converter
¥ ASCII File Input Interface
This example shows how to use the Begin Repeat and End 

Repeat feature whenever there are multiple records to supply 
values for a template message. Here there are several meetings 
scheduled.

NOTE: The format of the text Þle in this example conforms to 
the ÒBasic DAQ FormatÓ as described in ÒAppendix P: 
Formats of ASCII-delimited ÞlesÓ on page 125.

1. In Editor, create a template with ÒRoom numberÓ, 
ÒTimeÓ, and ÒGroupÓ:

2. Place the cursor in the message at the beginning of the 
text to be repeated. From the Options menu, choose Begin 
Repeat.

Begin Repeat icon
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3. Place the cursor at the end of the text to be repeated, then 
from the Options menu, choose End Repeat.

4. In a new Notepad Þle, on the Þrst line, type 
ÒMeeting1,alecÓ with no spaces before or after the 
commas.

5. On the next lines, type room numbers, times, and groups 
as below, with no spaces before or after the commas. The 
Notepad Þle should look like this:

6. Save the Notepad Þle. Make a copy of it. Rename the copy 
with the extension as Ò.daqÓ. Move the copy to the inbox 
directory of the ASCII File Input Interface.

7. When the text Þle gets merged with the template and 
sent as a message, it will be displayed as in the following:

Meeting in
Room #100 at 8:30: Personnel
Room #100 at 10:00: Personnel
Room #200 at 10:00: Sales and Marketing
Room #201 at 2:00: Executive Conference

Begin Repeat icon End Repeat icon

NOTE
The Repeat function repeats 
an entire block of characters 
in a message. However, in the 
text file, you only supply the 
values for the text markers.
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Using email

You can use email to send changeable data to Smart Alec so 
that it can be merged with a template message and sent to a sign 
or to a pager. For example:

¥ You can use a template message with just a single text 
marker to be merged with a block of free-form email text.

¥ You can have a template message with given text plus 
several text markers for speciÞc data from email.

Setting up and using email with Smart Alec— the basic process
1. In your email server application, create a user called 

Smart Alec. Since there are a number of email server 
applications, you will need to refer to your email server 
documentation for a section about ÒHow to add an email 
userÓ. Using that information, add a user called Smart 
Alec, or ask your system administrator.

2. In Editor, create a template message located on the Smart 
Alec server. This template will be used for sending email 
messages to designated locations, either signs or pagers. 
(See ÒUsing template messagesÓ on page 60 for detailed 
information about template messages and ÒExample 1 Ñ 
Displaying an email message on a signÓ on page 83 for 
an example.)
¥ To allow a block of free-form text to be sent to a sign, 

simply include one text marker Ð nothing else Ð in 
the template message.

¥ For more speciÞc messages, include formatting, text, 
and text markers as needed.
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3. In the Administrator, authorize users for email and 
templates. This is shown in ÒExample 1 Ñ Displaying an 
email message on a signÓ.

4. Finally, from the email server application, a message can 
be sent to the email user Smart Alec with the name of the 
template as the subject and the message to be sent in the 
body of the email. This is also shown in ÒExample 1 Ñ 
Displaying an email message on a signÓ.

Example 1 — Displaying an email message on a sign
This example shows how to send a message to a sign from an 

email system using a template message with three text markers.
All these components need to be running on the Smart Alec 

server:
¥ Microsoft Exchange (or your email server application)
¥ Email Gateway
¥ Message Server
¥ Editor
¥ Administrator
¥ Device Driver - Wired
¥ Alpha SA Protocol Converter
¥ ASCII File Input Interface
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In Editor
1. Create a new template following ÒExample 3 Ñ Creating 

a template message to merge with a text ÞleÓ on page 66. 

2. Select Submit > Setup Options and on the Submit Options 
tab, choose a Destination Location for a sign. For Message 
Mode, choose Run Schedules.
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3. On the Scheduled Options tab, choose Immediate Mode (for 
sending the message immediately) and set the Duration 
to 1 hour. Click OK to save the changes.

4. Save the template.

In the Administrator

5. Choose any user who is to send email with this template. 
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6. In that person's proÞle, add the new template. Click OK.

7. This shows authorization for the new template.
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8. Select the  button just to the right of the Email Address 
box. 

9. This will bring up a list of local email addresses. Choose 
the address belonging to the user and move it to the right 
side with the To--> button. Click OK.

NOTE
This capability is not currently 
available with Windows NT. See 
“Appendix Q: How to assign a user’s 
email name in Windows NT” on 
page 131 for more information.
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10. The chosen Local Email Address will be shown in the Email 
Address box. Click OK.

In the email system

11. Open a new email message.
12. For the addressee, type ÒSmart AlecÓ. For the subject, 

type the name of the template for which data is being 
supplied, shown in this example as ÒMeeting2Ó.

13. In the body of the message, type the text to be sent. The 
ÒMeeting2Ó template message includes three text 

HINT: Create a Smart Alec user 
called “Guest” for non-Smart 
Alec users to send email 
through Smart Alec. “Guest” is 
the default cross-reference.

After an Email Address is set, when Smart Alec receives email from this Email 
Address, it will cross-reference to this user to validate authorized templates.
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markers, for meeting time, room number, and group. So 
type: Ò9:30Ó,Ò205Ó,ÒPersonnelÓ.

¥ If the template has one SA Text Marker, the body of 
the message will Þll in the SA Text Marker. Quotes are 
optional around the body of the message.

¥ If the template has more than one SA Text Marker, the 
body of the message must be broken into sections for 
each of the SA Text Markers. Quotes and commas are 
used to break the body of the message into sections.

14. Send the email message.

In Smart Alec

15. The message displayed in this example will look 
something like this:
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Example 2 — Displaying a visual page on a sign
1. You could create this template message:

2. Then send this email message:

3. The resulting message on the sign would be:
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Appendices

Appendix A: Smart Alec system overview

Big perspective of Intelligent Messaging

ÒIntelligent messagingÓ allows you to:
¥ send and receive messages
¥ deÞne messages
¥ schedule messages
¥ determine where messages go
¥ manage message ßow
Intelligent messaging systems can acquire message input 

from many software systems. They accept and process input, 
coordinate data, and send messages out as needed. Message 
output goes to software systems or hardware devices to deliver 
the right message to the right locations at the right time using the 
right communication methods.

Messages received, processed,

combined, scheduled, converted

and delivered.

Created messages

E-mail

DDE 

Serial

ASCII files

Software

Applications

Pager

E-mail

Electronic message signs

Figure 1: Big picture of Intelligent Messaging
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User perspective of Smart Alec 

Smart Alec overview

Smart Alec can acquire information from email, ASCII, serial, 
and DDE and socket data sources, as illustrated above. Messages 
can also be created directly for input to Smart Alec through its 
Editor. Variable data is acquired and handled by the Variable 
Manager. Variables can be embedded in messages in real time 
and can also be used as triggers for messages.

At the heart of the system is the Message Server, which 
accepts and processes input, coordinates data, and sends it as 
messages to the output communication devices, such as ALPHA 
SA displays and alphanumeric pagers.

To get a message out to a given device, the message must be 
converted to a format which the device understands. This is done 
by protocol converters which convert signals from the Smart Alec 
system and send the signals to device drivers. These device 
drivers further interpret and process the signals and send them to 
the Þnal communication devices.

Email

ASCII

User

ALPHA SA signs

DDE, sockets

Pagers

Serial

Smart Alec ApplicationsData source Data output

This is an option that can be purchased separately.

Email Gateway

Editor

ASCII File Input Interface

ALPHA SA - Output Interface

Variable Manager

Serial data input interface

Pager - Output Interface1

1

1

EmailEmail - Output Interface1

Figure 2: User perspective of Smart Alec
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Technical perspective: acquire, process, distribute

Acquisition of data (“Data source”)

Input can come from any of many data sources, including:
¥ MAPI-compatible email Þles, such as Microsoft 

Exchange
¥ ASCII-delimited Þles, such as Schedule+ or Goldmine 

Day Planner
¥ Serial data stream processors, such as WinWedge or 

Dynacomm
¥ DDE-capable applications, such as WonderwareÕs 

InTouch or Microsoft Excel
¥ Socket communication applications
¥ The Editor, by allowing you to provide text for messages
¥ Smart Alec-speciÞc MSA-compatible Þles

Processing the messages (“Smart Alec applications”)

Processing is accomplished through software components of 
the Smart Alec system.

¥ The Administrator program allows you to set levels of 
security and access to locations, variables, and templates.

¥ The ASCII File Input Interface merges templates with 
ASCII data from email and ASCII Þles.

¥ The Message Server is responsible for delivering 
messages to the proper locations at the proper time. It 
processes all messages, displays a log of all current 
messages, and sends messages as required.

¥ The Variable Manager manages data to be used as 
variables in messages, makes those variables available 
for use in messages, displays the list of variables linked 
to the system, and works with the Message Server to 
start and stop messages when variables pass pre-deÞned 
thresholds.

¥ The Message Viewer lets you monitor and delete 
messages.

Distribution of messages (“Data output”)

Output from the Message Server is converted to formats 
appropriate to each hardware communication device. Protocol 
converters, such as an ALPHA SA or pager protocol converter, 
transform each message into the proper format for the necessary 
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device driver(s). The device drivers, such as a modem or a 
wireless transmitter, process the signals and send them to the 
Þnal communication devices. The actual communication devices, 
such as an ALPHA SA display or a pager, display any messages.

Watching Smart Alec in operation

There are several user dialog windows whereby you can 
watch Smart Alec process and deliver messages:

¥ The Variable Manager allows you to request speciÞc 
variables from other programs and watch the values of 
the variables as they change in the system.

¥ The Message Viewer shows details of any active or 
pending messages. These include: owner, run period, 
message contents, variables used, destination location(s). 
You can also delete messages here.

¥ The Message ServerÕs Transaction Log displays active, 
pending, or complete messages, as well as identifying 
and processing characteristics.

¥ Each protocol converter shows the number of messages 
and variables it has processed, and can show additional 
details of their usage for a given output device.

¥ Each device driver shows settings, number of messages 
processed, and its status for a given output device.

So, with windows to the Smart Alec processing as described 
above, you can watch a message as it comes into the system and 
is processed by the Message Server, the protocol converter and 
the device driver. Then you can see each message as it is 
displayed.
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Appendix B: Smart Alec computer requirements

Make sure your hardware system Þts these requirements:
¥ Personal computer, IBM or compatible
¥ CD-ROM drive
¥ Mouse
¥ VGA or SVGA color monitor
In addition, the following is recommended:

Operating system (server)
Microsoft Windows 95 with 32 MB RAM, or Windows 
NT Workstation 4.0 with 32 MB RAM

Operating system (client)
Microsoft Windows 95 with 16 MB RAM, or Windows 
NT Workstation 4.0 with 32 MB RAM

Processor, minimum Pentium 125 MHz
Hard disk storage space 25 MB
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Appendix C: Device Driver information

A Device Driver is an application that communicates with an 
output device, such as a modem, pager, LAN, etc. 

Every Location uses a Device Driver. A Device Driver must 
be properly set up in order for the Smart Alec Server to send 
information to a Location.

The Þrst time the Administrator application is used, you will 
be asked to verify the properties of each Device Driver.

Property Format or valid values

Baud rate 9600
Connector (COM port) Com1, Com2, Com3, Com4
Parity None, odd, even
Data bits 7, 8
Service port Port number of print/terminal server on a LAN, e.g., “9101”.
Init/Initialization string Group of commands (e.g., “AT,”) for modem set-up; sent to the modem before 

the number is dialed. 
Dialing prefix Sequence to dial to get to an outside phone line, e.g., “9,”.
Phone number Standard telephone number. May include formatting characters such as 

commas, parentheses, or dashes.

Location

Alpha SA Pager

Wired LAN Modem Wireless
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Table 2: Device Driver Properties

Device Driver Property Value

Wired

Baud Rate

Connector (COM port)

Parity

Data Bits

Wireless

Tekk Inc
KS-960

Baud Rate

Connector (COM port)

Parity

Data Bits

TAP

Baud rate
Connector (COM port)
Parity
Data bits

Init string

Dialing prefix

Phone number
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Modem Device

LAN Service Port

Table 2: Device Driver Properties

Device Driver Property Value
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Appendix D: Location properties

A Location is a message destination. A Location may be 
composed of one or more ALPHA SA signs or a pager. Every 
Location has a Device Driver associated with it (see ÒAppendix 
C: Device Driver informationÓ on page 96).

Locations are created and set up in the Administrator. 
Basically, there are three types of Locations Ñ ALPHA SA, Pager, 
and Email:

Types of ALPHA SA Locations:

* Types of Pager Locations:

* Pager is an option that must be purchased from Adaptive 
Micro Systems.

* Email is an option that must be purchased from Adaptive 
Micro Systems.

* Email Locations:
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ALPHA SA Wired properties
This type of Location is composed of one or more ALPHA SA 

signs that are connected to a Server (or Client) computer that is 
running the Wired Device Driver.

In the Administrator, select File > New > Location > Alpha SA > 
Wired:

These are the 
Device Driver 
properties. 
(See 
“Appendix C: 
Device Driver 
information” 
on page 96.)

Select Send 
Test Message 
to verify that 
the devices at 
this Location 
can receive 
messages.
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Property Description

Name of Location 

Every Location must have a name. 

Hint: To remember which Device Driver is used, 
put the driver type in the Location name — for 
example, Engineering-Wired.

Address List

One or more unique numbers from 0 - 255 
separated by a comma or dash, that represent 
sign “addresses”. For example, typing 1-5 would 
mean that there are five ALPHA SA signs 
networked to this Location, and that one sign has 
an address of 1, another has 2, etc.

To change the address of a sign, see “Appendix 
N: Setting the address of an ALPHA SA sign” on 
page 123.

Time Zone Adjust
Difference, in number of time zones, between the 
time where a server is located and the time zone 
where a client is located

Table 3: Properties for ALPHA SA wired Locations

Location name Address(es)
Time 
zone 

adjust
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ALPHA SA Wireless properties
This type of Location is composed of one or more ALPHA SA 

signs that are connected to the Server via a wireless data receiver 
attached to each sign. In order to transmit messages from the 
Server to a data receiver, either a wireless transmitter must be 
connected to the Server Ñ for TAP (Local) or Tekk Inc KS-960 Ñ or 
a modem must be connected to the Server Ñ for TAP (Wide Area).

In the Administrator, select File > New > Location > Alpha SA > 
Wireless. Then select either TAP (Wide Area), TAP (Local), or Tekk 
Inc KS-960:

TAP (Wide Area)

These are the Device Driver 
properties. (See “Appendix C: Device 
Driver information” on page 96.)

Select Send Test Message to 
verify that the devices at this 
Location can receive messages.
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TAP (Local)

These are the Device 
Driver properties. (See 
“Appendix C: Device Driver 
information” on page 96.)

Select Send Test Message to 
verify that the devices at this 
Location can receive messages.
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Tekk Inc KS-960

These are the Device 
Driver properties. (See 
“Appendix C: Device Driver 
information” on page 96.)

Select Send Test Message to 
verify that the devices at this 
Location can receive messages.
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Table 4: Properties for ALPHA SA wireless Locations

Location name Address(es) Capcode
Time 
zone 

adjust



Appendix D: Location properties 

106 Appendices

ALPHA SA LAN properties
This type of Location is composed of one or more ALPHA SA 

signs that are connected to the Server via a print server.
In the Administrator, select File > New > Location > Alpha SA > 

LAN:

These are the Device 
Driver properties. (See 
“Appendix C: Device Driver 
information” on page 96.)

Select Send Test Message to 
verify that the devices at this 
Location can receive messages.
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Table 5: Properties for ALPHA SA LAN Locations

Location name
SIgn

Address

Print 
server

IP 
Address

Time 
zone 

adjust
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ALPHA SA Modem properties
This type of Location is composed of one or more ALPHA SA 

signs that are connected to the Server via a modem. (There must 
be a transmitting modem, attached to the Server, and a receiving 
modem, attached to a sign.)

In the Administrator, select File > New > Location > Alpha SA > 
Modem:

These are the Device 
Driver properties. (See 
“Appendix C: Device Driver 
information” on page 96.)

Select Send Test Message to 
verify that the devices at this 
Location can receive messages.
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Table 6: Properties for ALPHA SA modem Locations

Location name Address Phone no.
Time 
zone 

adjust
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Pager properties
This type of Location is composed of an alphanumeric pager 

connected to the Server via a wireless transmitter.
In the Administrator, select File > New > Location > Pager. 

Then select TAP (Wide Area), TAP (Local), or Tekk Inc KS-960.
ÒALPHA SA Wireless propertiesÓ on page 102 also applies to 

Pager properties.

Table 7: Properties for Pager Locations

Name of the location
Cap code for 

pager

Time 
zone 

adjust
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Appendix E: User properties

The following table is provided to make it easier to keep 
track of User properties:

Table 8: Properties for Users

User name Password Email address

Access rights

Locations Variables Templates
Administrator 

access?
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Appendix F: Network types

Use the following to determine whether or not to install 
Smart Alec software on a single computer or on multiple 
computers.

Single computer
In this conÞguration, both the Smart Alec Server and the 

Client software are installed on a single computer. This is the 
easiest and the least expensive option and assumes one person Ñ 
the system administrator Ñ will be responsible for both system 
maintenance and message creation.

Multiple computers
In this conÞguration, the Smart Alec Server and the Clients 

are each installed on a separate computer. This is the most 
effective option as message creation responsibility is distributed 
among multiple Clients, not just a single administrator. Also, the 
system is most efÞcient if the Smart Alec Server resides on its 
own computer.

Smart Alec Server
If the system administrator is 
going to manage Smart Alec 
from this computer, then also 
install the Client software on 
this computer. Smart Alec Client Smart Alec Client Smart Alec Client

EtherNet
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Appendix G: Troubleshooting

Where to go for additional help
If you need assistance, please follow this procedure:
1. Refer to relevant topics in this manual.
2. Refer to on-line Help for pertinent software.
3. Contact your authorized Smart Alec reseller.

What you need to provide when you need assistance
If you need technical assistance, you will need to provide:
¥ full description of the problem
¥ the sequence of steps that lead up to the problem
¥ computer system hardware and relevant software 

version numbers
¥ the version number of Smart Alec
¥ the product serial number Ð found on the outside 

packaging and on the registration card
¥ the version number of any relevant Smart Alec 

components, found in Help > About for that component.
For more information, you can visit Adaptive Micro SystemsÕ 

World Wide Web site at: http://www.ams-i.com.
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Appendix H: What Modes are available on signs

Modes are special effects used in the Editor to change the way 
a message appears on a sign:

Table 9: Modes available on signs.

Sign
(FM = Full Matrix,

CM = Character Matrix, 
LM = Line Matrix)

Modes
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ALPHA
sign Ty
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C
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Series 200 FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Series 300 FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Series 4000 FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Series 7000 FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Big Dot FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Alphavision FM FM ● ● ● ● ● ● ● ● ● ● ●

Alphavision CM CM ● ● ● ●

790i FM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Solar FM ● ● ● ● ● ● ● ● ● ●

Director CM ● ● ● ●

2.1-inch CM CM ● ● ● ●

3.2-inch CM CM ● ● ● ●

PPD LM ● ● ● ● ● ● ● ● ● ● ● ● ● ● ●
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Appendix I: What Characters & Colors are available on signs

The Editor allows you to change the character shapes and 
colors that appear in sign message:

Table 10: Characters and Colors available on signs.

Sign
(FM = Full Matrix,

CM = Character Matrix,
LM = Line Matrix)

Characters
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sign Ty

pe

Series 200 FM ● ● ● ● ● ● ● ●

Series 300 FM ● ● ● ● ● ● ● ●

Series 4000 FM ● ● ● ● ● ● ● ● ● ● ●

Series 7000 FM ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Big Dot FM ● ● ● ● ● ● ● ●

Alphavision FM FM ● ● ● ● ● ● ● ● ● ● ● ● ● ●

Alphavision CM CM ● ● ● ● ●

790i FM ● ● ● ● ● ●

Solar FM ● ● ● ● ● ● ● ● ● ●

Director CM ● ● ● ● ●

2.1-inch CM CM ● ● ● ● ●

3.2-inch CM CM ● ● ● ● ●

PPD LM ● ● ● ● ● ● ●

NOTE: Sign names ending in “C” or “T”, such as 4120C or 37-90T, have color capabilities. Sign names ending in 
“R”, such as 4120R or 37-90R, can display in red only.
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Appendix J: What display Options are available on signs

Options is an Editor command composed of special features, 
like animation, and is used by the software to enhance the way a 
message appears:

Table 11: Options available on signs.

Sign
(FM = Full Matrix,

CM = Character Matrix,
LM = Line Matrix)

Options
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Series 200 FM ● ● ● ● ● ● ● ● ● ● ●

Series 300 FM ● ● ● ● ● ● ● ● ● ● ●

Series 4000 FM ● ● ● ● ● ● ● ● ● ● ● ●

Series 7000 FM ● ● ● ● ● ● ● ● ● ● ● ●

Big Dot FM ● ● ● ● ● ● ● ● ● ● ●

Alphavision FM FM ● ● ● ● ● ● ● ● ● ● ●

Alphavision CM CM ● ● ● ● ● ● ● ● ● ● ●

790i FM ● ● ● ● ● ● ● ● ● ● ●

Solar FM ● ● ● ● ● ● ● ● ● ● ● ●

Director CM ● ● ● ● ● ● ● ● ● ● ●

2.1-inch CM CM ● ● ● ● ● ● ● ● ● ● ●

3.2-inch CM CM ● ● ● ● ● ● ● ● ● ● ●

PPD LM ● ● ● ● ● ● ● ● ● ● ●
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Appendix K: Smart Alec components

The server components or the client components, or both 
server and client components (or applications) can be installed on 
a computer.

Component name Component function

S
er

ve
r

C
lie

nt

Administrator
Allows administrator to manage the system 
components

✓

ASCII File Input Interface
Combines ASCII-delimited text files with 
predefined Templates

✓

Clock Variable Demo An example of a DDE server. ✓

Device driver - LAN Sends output to a LAN device (print server) ✓

Device driver - Modem Sends output to a modem ✓

Device driver - TAP Sends output to a TAP-protocol device ✓

Device driver - Wired Sends output to a wired device ✓

Device driver - Wireless Sends output to a wireless transmitter ✓

Editor
Allows the creation and editing of messages and 
templates

✓

Email Gateway Processes mail sent to Smart Alec ✓

Message Viewer
Allows you to view messages currently in Smart 
Alec

✓

Message Server
Processes and logs all messages that go through 
Smart Alec

✓

Pager - Output Interface Converts output to pager protocol ✓

Alpha SA - Input Interface Converts output to ALPHA SA sign protocol ✓

Set Password Allows you to change your password ✓

Smart Alec Launch Configuration Utility Allows you to select which components will start 
when Smart Alec Launch Utility is selected

✓

Smart Alec Launch Utility ✓

Variable Manager Collects DDE variable information ✓

License information
Licenses – Users 5
Licenses – Variables 100
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Appendix L: Understanding line positions (Top, Middle, Bottom, Fill)

The Òline positionÓ refers to where a message can be 
displayed on a sign Ñ the top, middle, bottom, or Þll positions. 
Line position are available with most Modes (e.g., Hold, Snow, 
Sparkle, etc.):

Line 
position

Top

Middle

Bottom

Fill

What appears in the Editor: What is displayed on a 2-line sign:
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Appendix M: Understanding how text and graphics are displayed on signs

Each sign is made up of a display area composed of columns 
and rows of LED ÒpixelsÓ which can be turned on and off. These 
pixels can also be displayed in different colors, depending on the 
type of sign. The display areas for signs are in a table below.

Columns and rows make up a sign
For example, a 4120C (or 4120R) sign has a total display area 

of 120 x 16:

Sign
Display area
(col x rows)

Colors

BETA-BRITE Series
BETA-BRITE 80 x 7

8

BETA-BRITE BIG DOT 80 x 7
ALPHA Big Dot 80 x 7

215 Series
215 90 x 7

215C 90 x 7

300 Series
320C 120 x 7
330C 180 x 7

4000 Series

4120R 120 x 16

3

4120C 120 x 16
4160R 160 x 16
4160C 160 x 16
4200R 200 x 16
4200C 200 x 16
4240R 240 x 16
4240C 240 x 16

7000 Series
7120C 120 x 24
7160C 160 x 24
7200C 200 x 24

Outdoor displays 790i 90 x 7
ALPHAVISION Display areas from 128 x 32 to 256 x 128.

NOTE: Sign names ending in “C”, such as 4120C, have color capabilities. Sign names ending in “R”, such as 4120R, 
can display in red only.

Columns = 120

R
ow

s 
=
 1

6
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Text comes in four basic sizes
The Characters menu displays a list of available text sizes, 

such as 15/16 Row Normal and Ten Row, and options, such as Wide 
and Flashing:

The four basic text sizes are 15/16 Row (Normal and Fancy), 
Ten Row, Seven Row (Normal and Fancy), and Five Row.

Below are examples of how the message ÒLas Vegas $85, 
Chicago $199Ó would appear on a 2-line 4120C or 4120R sign 
using all four basic text sizes (except Ten Row):

15/16 Row Normal

In this type size, characters are 15 or 16 rows high and about 
9 columns wide:

Seven Row Normal

In this type size, characters are 7 rows high and about 6 
columns wide:

Text sizes are selected from the 
Characters menu. (The default 
text size is Seven Row Normal.)

Other text options can also be selected. For 
example, Wide makes a font look “bold”.
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Five Row

In this type size, characters are 5 rows high and about 5 
columns wide:

Graphics must be “bitmapped to a sign’s columns and rows
Before creating a graphic for a particular sign, you must Þrst 

know the display area of that sign.
The columns and rows that make up a signÕs display area 

also represent the maximum pixel size of a graphic that can be 
displayed on a sign.

For example, a 4120C (or 4120R) sign has a total display area 
of 120 columns x 16 rows. This means that the largest graphic that 
could be displayed would be to be 120 pixels wide x 16 pixels 
high: (The graphic could, of course, be smaller than this.)
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A graphic may be too big for some signs

Because signs vary in size, make sure that your graphics are 
designed to Þt on all your signs or at least on one of your signs:

A graphic may be the wrong color for a sign

Only ALPHA SA sign names ending in ÒCÓ have color 
capabilities (like the 7120C). ALPHA SA sign names ending in 
ÒRÓ, like the 4120R, can only display red:

Though this 32 x 16 pixel graphic fits 
easily on a 2-line sign like a 4120C, 
only the top part of the graphic 
appears on this smaller 1-line sign.
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The entire graphic 
appears in red.

This border will be yellow.

This line will be red. This line will be green.
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Appendix N: Setting the address of an ALPHA SA sign

An ALPHA SA sign comes from the factory with an 
ÒaddressÓ of 0. However, this address can be set to any number 
between 0 and 255.

Giving a sign a unique address allows you to send messages 
to a single sign that is part of a network of signs.

The following instructions describe how to change the 
address of an ALPHA SA sign with an infrared Remote Control 
keyboard.

NOTE: The infrared Remote Control can not be used with all 
ALPHA SA signs. On some ALPHA SA signs, an 
internal DIP switch must be set to change the address. 
See the documentation that came with your sign.

1. Press the PROGRAM key.
2. Press the BACK key until SET SERIAL ADDRESS or SET 

SERIAL appears on the sign.
3. Press the ADV key and the signÕs current address will 

appear, such as SERIAL ADDRESS = 000.
4. Type the new address, like 010.
5. Press the RUN key twice to enter the new address.

Remote 
Control
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Appendix O: DDE servers

Working with existing DDE servers
The Variable Manager acts as a DDE client. It needs a DDE 

server to communicate with in order to create Variables. Many 
existing programs already function as DDE servers, such as 
WonderwareÕs Intouch and Microsoft Excel. To use these or any 
other DDE-server applications with the Variable Manager, you 
must Þnd the service, topic, and item names which are to supply 
values for the Variables from the DDE server. The applicationÕs 
documentation should provide these. 

The Variable Manager establishes a request-and-advise loop 
when it requests an item from a DDE server. This means that the 
Variable Manager requests the itemÕs value once from the DDE 
server and then the DDE server is responsible for sending the 
item to the Variable Manager each time the item changes value (as 
long as the conversation between the Variable Manager and server 
has not been broken).

If you have a custom application which is not a DDE server 
but is one which you would like to use as a source of Variables for 
Smart Alec, there is an example which shows you how to create a 
DDE server:

¥ CLOCKSRC.EXE, in the ÉVARMNGR\CLOCKSRC 
directory Ð a Visual C++ (version 4.x or greater) example 
which has DDE functionality encapsulated in C++ 
classes. The README.TXT Þle included with the source 
code provides additional information.

NOTE: When using DDE, Variable Manager must be installed 
on the same computer as the external data source, and 
that source must be Windows-based. When using 
NetDDE, Variable Manager must be installed on the 
same network as the external data source, and that 
source must be Windows-based. When using socket 
communications, Variable Manager can be installed 
anywhere, but the external data source need not be 
Windows-based.



Appendix P: Formats of ASCII-delimited files 

Appendices 125

Appendix P: Formats of ASCII-delimited files

The ASCII File Input Interface uses data Þles as sources of data 
to merge with Templates created in Editor. There are four 
variations of the traditional ASCII-delimited Þle format. Each 
variation provides a little bit different functionality. All variations 
are ßat Þles which use commas as Þeld delimiters.

File formats

Basic DAQ Format

The basic .DAQ Þle has one header record and any number 
of data records.

Record One = Template Name,Owner Name
Record Two = Field1,Field2,Field3,…
Record Three = Field1,Field2,Field3,…

EXAMPLE

Birthday,Alec
Bill,29,March 29
Bob,30,April 1
Betty,28,April 10

Registered Extension Format

The registered extension format Þle has the type of its 
extension (e.g., Ò.xlsÓ) and the owner (e.g., Excel) registered for 
use with a particular Template through the Administrator. This 
eliminates the need for the header record (with Template name 
and Owner name) to be in the Þle. Only data records are needed.

Record One = Field1,Field2,Field3,…
Record Two = Field1,Field2,Field3,…
Record Three = Field1,Field2,Field3,…

EXAMPLE

Bill,29,March 29
Bob,30,April 1
Betty,28,April 10
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Extended DAQ Format

An extended .DAQ Þle is used with a template that contains 
at least one @submit Þeld. The Þle has a header record with values 
for the @Submit Þelds in the template. This Þle also has another 
header record (with Template name and Owner name) and any 
number of data records.

Record One =Template Name,Owner Name
Record Two = Destination,Start Date,Start Time,End Date,End Time, 

Duration
Record Three = Field1,Field2,Field3,…
Record Four = Field1,Field2,Field3,…

EXAMPLE

Birthday,Alec
Office,,,,,5:00:00
Bill,29,March 29
Bob,30,April 1
Betty,28,April 10

Extended Registered Extension Format

An extended .DAQ Þle is used with a template that contains 
at least one @Submit Þeld. This Þle has a header record with 
values for the @Submit Þelds in the template.

The registered extension format Þle has the type of its 
extension (e.g., Ò.docÓ) and the owner (e.g., Microsoft Word) 
registered for use with a particular Template through the 
Administrator. This eliminates the need for the header record 
(with Template name and Owner name) to be in the Þle. One 
header and any number of data records are used.

Record One = Destination,Start Date,Start Time,End Date,End Time, 
Duration

Record Two = Field1,Field2,Field3,…
Record Three = Field1,Field2,Field3,…

EXAMPLE

Office,,,,,5:00:00
Bill,29,March 29
Bob,30,April 1
Betty,28,April 10
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Format of @Submit fields in the header record
General

¥ .DAQ Þles are in ASCII-delimited Þle format. 
¥ Parameters included in these Þles will override any 

parameters deÞned in a template message.
Comma delimiters

¥ Commas are used for separating the @Submit Þelds.
¥ Do not include spaces before or after the comma, 

except when the space is part of the data.
¥ For the template/owner header, both Þelds are 

needed, with one comma between them.
¥ For the scheduling header, there must be Þve (5) 

commas total. There does not have to be anything 
between them, and if there is not, then a comma acts 
as a placeholder. However, you should include all 
the Þelds logically needed. For example, if you have 
a start time and date, you should also have either a 
duration or a stop time and date.

Destination

¥ Must be typed exactly as is shown in the Editor lists 
of Locations in Submit > Submit Options. 

¥ This is case-sensitive, that is, use upper and lower 
case as appropriate.

¥ If the Location is a group, then the Destination must 
be typed with (Group) at the end.

Date

¥ Do not use commas within the date Þelds! Commas 
are reserved for separating the @Submit Þelds.

¥ Use month-day-year format.
¥ It is best to use backslashes (/) or dashes (-) as 

separators. However, words are acceptable for the 
month. Do not include commas!

Time

¥ Use military time, that is, a 24-hour clock.
¥ Use the format HH:MM:SS. Default start time is 

immediate.
¥ For example, 18:45:22, for 22 seconds past 6:45 PM.

Duration

¥ Use the format HH:MM:SS. Default is two minutes.
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Format of fields in data records
Comma delimiters

¥ Commas are used for separating the data Þelds.
¥ There is no comma at the end of any record.

Field values

¥ If there is a comma within the data for a Þeld, enclose 
the entire Þeld data in quotes.

Field numbers

¥ In the template message, the Þeld number 
corresponds to the sequential number of the desired 
Þeld in the ASCII-delimited data Þle.

¥ For example, assume you have a data Þle with a total 
of Þfty Þelds. You only want to use three of these 
Þelds. The three you want are number 40, 21, and 35, 
in that order in the template message. So when you 
enter them in the template message, specify the Þrst 
text marker Þeld as number 40, the second as 21, and 
the last as 35.

The value of the Field Number 
here coordinates with the 
sequence of the fields in a text 
file which can supply the values. 
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Registering an extension and owner
You can associate a speciÞc template with a unique type of 

Þle extension for a Þle that provides data for a variable in that 
template. With this, Smart Alec automatically merges a Þle with 
that extension together with the template to process a complete 
message.

While this example shows a template being associated with 
Microsoft Word, typically, this would be associated with the 
output Þle from a custom application.

1. In the Administrator, select the template to be used and 
then choose Edit > Properties.

2. The Template Properties screen will appear. Enter the 
Extension for the type of Þle you would like this Template 
to use, e.g., ÒdocÓ for a Microsoft Word document.
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3. Enter the Owner who will be submitting the ASCII Þle 
with that extension, e.g., ÒMSWÓ for Microsoft Word. (An 
Owner is any person or application which will submit 
information in some way to Smart Alec. Owner is used as 
a label in the Message Server so you can recognize where 
the data is coming from. Owner can be up to three 
characters.)

4. Select OK. This template will now be used any time an 
ASCII Þle with that extension is put in the ASCII File 
Input Interface's Inbox. You wonÕt need the header record 
with Template name and Owner name in the Þle.
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Appendix Q: How to assign a user’s email name in Windows NT

You must manually change the CROSSREF.INI Þle in 
Windows NT. Use this description and example of the sections 
and lines which are needed to assign a user and an email identity:

Description

[Users]
Login Name=User profile .INI file name

[Email Users]
Local Email Address=User profile .INI file name

Example

[Users]
Alec=ale

[Email Users]
Administrator=ale



Glossary 

132 Appendices

Glossary

ASCII file
An ASCII Þle comes from an information source, such as 

software or email, and includes ASCII text strings and possibly 
some submission options. In most cases, the ASCII Þle includes a 
template name (except if the template was previously associated 
with a particular type of ASCII Þle through the Administrator).

Destination
A selected location where a message will be sent.

Device
In general, any kind of hardware component that is part of 

your computer system. However, in Smart Alec, the term device 
is limited to hardware components to which you send messages. 
Examples are: signs, modems, and pagers. All devices need 
Device Drivers.

Device Driver
Software and parameter settings needed to communicate 

properly with a hardware device.
The Smart Alec system includes the following device drivers:
¥ Wired Ñ Uses cables to connect ALPHA SA signs into a 

network, and messages are sent over this cabling. A 
direct com port connection works best when all the 
devices are in one building.

¥ Wireless Ñ Uses a wireless receiver attached to a display 
device. The advantage of this connection method is that 
wiring does not have to be strung between devices. 
Messages are sent from your computer to wireless 
receivers and pagers via a transmitter, attached to your 
computer, which broadcasts messages to these receivers. 
The distance from your transmitter to the receivers is 
limited.

¥ Modem Ñ Uses a modem attached to your computer 
and one or more modems attached to a remote device. 
When a message is sent, it is transmitted to the remote 
device when the computer modem calls the deviceÕs 
modem. A modem connection is often used for devices 
that are not in the same building and possibly not in the 
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same city. It works best when message data does not 
change rapidly.

¥ TAP Ñ Uses a wireless receiver attached to a device, 
either a display or a pager. A message is sent from your 
computer to an attached modem. The modem then dials 
a paging service, such as SkyTel, and this paging service 
actually transmits the message to the wireless receiver. 
The distance between your transmitter and the receivers 
is limited only by the range of the paging service.

¥ LAN Ñ Uses a Local Area Network cabling system to 
transmit messages to a device on the LAN with an IP 
address.

NOTE: You may have purchased devices from other third 
party sources. These are not supported by Adaptive 
Micro Systems. You will need to consult the third party 
source for any needed assistance.

Display message 
The actual message that will be displayed at the 

communications device. It includes the message text - plus any 
embedded variable data. For example, message text might 
include headings of plant run rates. Below the headings, the 
variable values (run rates for each production line) are embedded 
in the message and displayed as they change. Display messages 
also include the associated submission options. Finally, display 
messages have been converted to the format required for the 
selected display device(s), such as an ALPHA SA sign or an 
alphanumeric pager. The layout follows:

Dynamic Data Exchange
Dynamic Data Exchange, or DDE for short, is a programming 

method by which Windows-based computer applications can 
exchange data when running simultaneously, generally on the 

Display message (in output device format)

Submission options Message text

User/owner Destination(s)
Schedule or 

active 
period

Priority

 Message 
text with 

embedded 
variables

Display 
format



Glossary 

134 Appendices

same computer. This way they can ÒcommunicateÓ directly and 
actions in one system can be triggered by data in another system.

External data source
A source of data or information outside of the Smart Alec 

system. Also known as a data server. One example of an external 
data source could be a production line system, such as Intellution 
or WonderWare, providing machine statistics, like the number of 
parts produced per minute or a machine's temperature. Another 
example of an external data source could be a Microsoft Excel or 
Lotus 1-2-3 spreadsheet.

Location
An individual or group of output communication devices, 

such as ALPHA SA signs, pagers, or other communication 
devices. Examples of Locations could be the vice presidentÕs 
pager, the companyÕs intranet site, or an ÒOfÞceÓ Location which 
includes all ALPHA SA signs in the ofÞce area of a company. A 
Location is a message destination. Each Location has a name and 
other information, such as baud rate or address.

Message
A Smart Alec message is composed of two necessary parts: 

the message text and the submission options, as deÞned below.

Message text

The text of a message, including optional links for variables 
that indicate where variables will be displayed at the 
communications device. Message text also includes the format in 
which the information will be displayed (such as red and yellow 
ßashing LED letters).

Submission options

The properties of a message that enable Smart Alec to deliver 
that message at the right time to the right place. Typically, these 
properties are assigned in the Editor. Submission options include 
the user/owner of the incoming information, the destination(s) 
where the message should be sent, the priority, and the schedule 
of the message. Messages are scheduled using either preset 
schedules or an active period started and stopped by variables as 
triggers:

¥ Some messages have pre-set schedules Ñ they run at a 
given time for a given length of time. For example, an 
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employee greeting can be set to run every day at 8:00 AM 
for an hour, factory statistics might run all day, or an 
email that pages MIS might be set to run immediately as 
soon as it is submitted to Smart Alec.

¥ Other messages run only during an active period, when 
triggered by a changing variable value. As values for that 
variable stream into Smart Alec, the Variable Manager 
keeps track of these values, watching for a threshold to 
be crossed in some way. When that happens, a message is 
triggered to run. For example, the variable for an alarm 
might take on the values 0 or 1: 0 if it is off, 1 if it is on. 
The variable is submitted to Smart Alec. If the alarm goes 
off, the variable changes from 0 to 1, triggering Smart 
Alec to send a message like ÒFire in the North Sector.Ó In 
another example, a temperature is continually sent to 
Smart Alec, which is set to trigger a message if the 
temperature rises above 90 degrees. The message is set to 
stop running when the temperature drops below 90 
degrees. The period during which the message runs is 
called the Òactive period.Ó

Protocol
A format, or a set of standards or rules for how things are 

supposed to be formatted or done. In the computer and 
communications world, protocols relate to the format and timing 
of data transmission between devices. The rules have to do with 
speed, tones used, and events that must be done in a speciÞc 
sequence so that hardware devices work together properly. ItÕs 
similar to the agreement we have to speak the same language.

Protocol Converter
Software to convert the format of the message to the protocol 

of a device. ItÕs a translator. For instance, Smart Alec has one to 

Message
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reformat messages to the required protocol for an ALPHA SA 
display, another for pagers, etc. A pager protocol converter is also 
responsible for keeping information up-to-date in messages that 
use variables.

Template
A blueprint of the text, formatting, and submission options 

or properties of a message. Created in the Editor, a template can 
be used over and over again with slight variations in the options. 
Typically a template pre-deÞnes most of the message text and 
submission options, leaving key elements blank for use in 
recurring messages. In a template, some text is always missing, 
indicated by a Òtext markerÓ which acts like a placeholder 
inserted in the template. In some cases, submission options, like 
the destination location or active period are missing from the 
template. The user then instructs Smart Alec that the information 
will be provided Òat submitÓ time, when the message is 
submitted for display. Key elements are:

For example, a template might include the text: Happy 
Birthday to [text marker]. Various peoplesÕ names will later be 
inserted into the text marker space. New text to Þll in the text 
marker space may be provided directly through the Editor or may 
be supplied in an ASCII Þle from an outside information source 
or email.

Submission options may also be updated through the Editor 
or provided in an incoming ASCII Þle. For example, email always 
provide the user/owner information and text to an associated 
email template. The pre-deÞned template determines the 
locations and active period. 

Template

Submission options Message text
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submit” time
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User/owner
Any person who is both authorized and set up to submit 

information in any way to Smart Alec.
Each user has not only a name and password, but can also 

have an email address and a list of authorized locations, 
templates, and/or variables that person can use. In addition, one 
or more users may be authorized as a system administrator. The 
number of users active at the same time is limited only by the 
number in your license agreement.

Variable
A variable represents real-time data that changes (e.g., 

temperature or production rates, security lock status, alarms.) Its 
value changes so itÕs called a variable.Ó Variable values are 
typically acquired and handled by the Variable Manager through 
Smart AlecÕs DDE or serial interfaces. Variables are embedded in 
messages (at variable links) in real time. The value of a variable 
gets Þlled in wherever the variable is used in a message and is 
refreshed as the value changes. Variables can also be used to 
trigger messages and events to start and stop.

As an example, you could have a variable called 
ÒTemperatureÓ which is continually Þlled in with values from a 
thermometer, changing whenever there is at least a 1-degree 
change at the thermometer. Whenever ÒtemperatureÓ equals or 
exceeds 212¡ F, an alarm sounds.
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